Maven Install Plugin
  1. Maven Install Plugin
  2. MINSTALL-33

mvn install:install-file should create appropriate entries so that dependencies with version ranges will use installed file.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: install:install-file
    • Labels:
      None
    • Environment:
      all
    • Number of attachments :
      0

      Description

      when using install:install-file it should cooperate with the code that handles versions that don't have an explicit version, but specify a version range. For example, if I install hibernate-3.2.0rc4, and my pom.xml has the hibernate dependency specified as:

          <dependency>
            <groupId>hibernate</groupId>
            <artifactId>hibernate</artifactId>
            <version>[3.2.0rc4,)</version>
          </dependency> 
      

      maven will complain that it cannot find the hibernate version 3.2.0rc4. However if the dependency is specified as :

          <dependency>
            <groupId>hibernate</groupId>
            <artifactId>hibernate</artifactId>
            <version>3.2.0rc4</version>
          </dependency>
      

      then the project builds successfully.

        Activity

        Dennis Lundberg added a comment -

        Was the hibernate dependency installed into your local repository using install:install-file?
        If so, what command line parameters did you use? What directories were created in your local repository and which files were installed?

        Robert Scholte added a comment -

        No feedback from user, so closing it.
        Also this looks more like an old Maven core issue rather then something caused by this plugin.


          People

          • Assignee:
            Robert Scholte
            Reporter:
            Patrick Moore
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: