Mojo's GWT Maven Plugin
  1. Mojo's GWT Maven Plugin
  2. MGWT-228

When running with GWT 2.1.0 the plugin require gwt-dev-<platform> jars

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Not A Bug
    • Affects Version/s: 1.2
    • Fix Version/s: 2.1.0
    • Labels:
      None
    • Environment:
      OpenSuse 11.3 86-64, maven 2.2.1
    • Testcase included:
      yes
    • Number of attachments :
      1

      Description

      When compiling with GWT 2.1.0 I does this:

      [INFO] [gwt:compile

      {execution: default}

      ]
      [INFO] using GWT jars from project dependencies : 2.1.0 [WARNING] You should not declare gwt-dev as a project dependency. This may introduce complex dependency conflicts
      Downloading: http://repo1.maven.org/maven2/com/google/gwt/gwt-dev/2.1.0/gwt-dev-2.1.0-linux.jar
      [INFO] Unable to find resource 'com.google.gwt:gwt-dev:jar:linux:2.1.0' in repository central (http://repo1.maven.org/maven2)
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD
      [INFO] artifact not found - Unable to download the artifact from any repository

        Activity

        nicolas de loof added a comment -

        1.2 does not support gwt 2.1

        a new 2.1 version is planned for this, please wait for snapshots

        nicolas de loof made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 2.1.0 [ 16732 ]
        Resolution Not A Bug [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Alex Solovyev
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: