GMaven (OLD... DO NOT USE)
  1. GMaven (OLD... DO NOT USE)
  2. MGROOVY-170

Exceptions when reloading pom in idea 8.0 (and probably eclipse)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-rc-3
    • Fix Version/s: 1.0-rc-4
    • Component/s: None
    • Labels:
      None
    • Environment:
      idea 8.0 all windows/linux. Probably same problem is occuring in eclipse too. Maven 2.0.9
    • Testcase included:
      yes
    • Number of attachments :
      2

      Description

      When reloading the project from pom in idea8.0 I get the following exception:

      .apache.maven.plugin.PluginExecutionException: Mojo execution failed.
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:601)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:498)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmentForProject(DefaultLifecycleExecutor.java:265)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:191)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:149)
      at org.apache.maven.DefaultMaven.execute_aroundBody0(DefaultMaven.java:223)
      at org.apache.maven.DefaultMaven.execute_aroundBody1$advice(DefaultMaven.java:304)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:1)
      at org.apache.maven.embedder.MavenEmbedder.execute_aroundBody2(MavenEmbedder.java:904)
      at org.apache.maven.embedder.MavenEmbedder.execute_aroundBody3$advice(MavenEmbedder.java:304)
      at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedder.java:1)
      at org.jetbrains.idea.maven.embedder.MavenEmbedderWrapper$2.execute(MavenEmbedderWrapper.java:87)
      at org.jetbrains.idea.maven.embedder.MavenEmbedderWrapper$5.execute(MavenEmbedderWrapper.java:207)
      at org.jetbrains.idea.maven.embedder.MavenEmbedderWrapper$5.execute(MavenEmbedderWrapper.java:204)
      at org.jetbrains.idea.maven.embedder.MavenEmbedderWrapper$6.run(MavenEmbedderWrapper.java:220)
      at com.intellij.openapi.application.impl.ApplicationImpl$5.run(ApplicationImpl.java:2)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:10)
      Caused by: org.apache.maven.plugin.MojoExecutionException: No providers found matching selection: default
      at org.codehaus.groovy.maven.plugin.MojoSupport.execute(MojoSupport.java:85)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:579)
      ... 22 more
      Caused by: org.codehaus.groovy.maven.feature.ProviderException: No providers found matching selection: default
      at org.codehaus.groovy.maven.runtime.loader.DefaultProviderManager.select(DefaultProviderManager.java:111)
      at org.codehaus.groovy.maven.plugin.ProviderMojoSupport.provider(ProviderMojoSupport.java:108)
      at org.codehaus.groovy.maven.plugin.ComponentMojoSupport.doExecute(ComponentMojoSupport.java:58)
      at org.codehaus.groovy.maven.plugin.MojoSupport.execute(MojoSupport.java:69)
      ... 23 more

      If I turn on the logging I get the enclosed stack trace (attachment). It seems like plexus is probably not initialized properly (or in some unexpected state). This is using maven 2.0.9. I have seen other reports that this is also happening in eclipse.

      I have tried debugging this to find more details but It is really hard because there is some "compatibility" aop involved. There may also be a version number issue, since maven 2.0.9 does not seem to be using the exactly same version of plexus (1.0-alpha-9-stable-1 for maven 2.0.9). I hope you actually understand enough plexus to make heads/tails of this problem, since it seems to be way above my head.

      The enclosed project (report2.tar) can be opened in idea8.0 (and probably eclipse). If you make a symbolic change to the pom.xml and choose a re-import, the problem is reproducable 100%.

      1. report2.tar
        90 kB
        Kristian Rosenvold
      2. stackTrace1.txct
        13 kB
        Kristian Rosenvold

        Activity

        Kristian Rosenvold added a comment -

        I must add; to get this stacktrace i had to rebuild without the gossip logger, I used slf4j-jdk14 version 1.5.6 instead. I have no idea what happens to the gossip output inside the ide.

        Kristian Rosenvold added a comment - - edited

        It turns out this enclosed stacktrace comes from an older version of plexus-container-default (probably alpha-7 or alpha-8). This can be seen by the AOP code in the stacktrace.

        I have looked around in the plexus repo and this AOP-aspect was only present in the source code from revision 7221 until 7792, while the earliest "alpha-9" version has revison number 7874. (alpha-9 does not use aspect-j weaving, which is in the stacktrace)

        Unfortunately one of the svn tags for alpha-7 or alpha-8 seems to be incorrect, so I cannot tell which version it is.

        It seems to me like idea and eclipse are messing up the classloader stuff somehow so that we're getting the wrong version of plexus-container-default.

        Kristian Rosenvold added a comment -

        This issue is solved by a combination of the latest snapshot build of rc-4 and the latest snapshot build of idea (version 9158 or higher).

        Kristian Rosenvold added a comment -

        Combined with IDEA 8 build 9158 or greater


          People

          • Assignee:
            Jason Dillon
            Reporter:
            Kristian Rosenvold
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: