Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0-rc-3
    • Fix Version/s: 1.0-rc-3
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      2

      Description

      I get these warnings...

      [WARNING] POM for 'org.codehaus.groovy.maven.support:slf4j-gossip:pom:1.0-rc-3-SNAPSHOT:runtime' is invalid. It will be ignored for artifact resolution. Reason: Failed to validate POM for project org.codehaus.groovy.maven.support:slf4j-gossip at Artifact [org.codehaus.groovy.maven.support:slf4j-gossip:pom:1.0-rc-3-SNAPSHOT:runtime]
      [WARNING] POM for 'org.codehaus.groovy.maven.runtime:gmaven-runtime-support:pom:1.0-rc-3-SNAPSHOT:runtime' is invalid. It will be ignored for artifact resolution. Reason: Failed to validate POM for project org.codehaus.groovy.maven.runtime:gmaven-runtime-support at Artifact [org.codehaus.groovy.maven.runtime:gmaven-runtime-support:pom:1.0-rc-3-SNAPSHOT:runtime]
      [WARNING] POM for 'org.codehaus.groovy.maven.support:slf4j-gossip:pom:1.0-rc-3-SNAPSHOT:runtime' is invalid. It will be ignored for artifact resolution. Reason: Failed to validate POM for project org.codehaus.groovy.maven.support:slf4j-gossip at Artifact [org.codehaus.groovy.maven.support:slf4j-gossip:pom:1.0-rc-3-SNAPSHOT:runtime]
      [INFO] [groovy:generateStubs

      {execution: default}

      ]
      [WARNING] POM for 'org.codehaus.groovy.maven.runtime:gmaven-runtime-support:pom:1.0-rc-3-SNAPSHOT:runtime' is invalid. It will be ignored for artifact resolution. Reason: Failed to validate POM for project org.codehaus.groovy.maven.runtime:gmaven-runtime-support at Artifact [org.codehaus.groovy.maven.runtime:gmaven-runtime-support:pom:1.0-rc-3-SNAPSHOT:runtime]

      then ...

      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] com/thoughtworks/qdox/JavaDocBuilder
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.NoClassDefFoundError: com/thoughtworks/qdox/JavaDocBuilder
      at org.codehaus.groovy.maven.runtime.support.stubgen.model.JavaDocParser.parseWithQDox(JavaDocParser.java:78)
      at org.codehaus.groovy.maven.runtime.support.stubgen.model.JavaDocParser.parse(JavaDocParser.java:55)
      at org.codehaus.groovy.maven.runtime.support.stubgen.model.ModelFactorySupport.javadocs(ModelFactorySupport.java:687)
      at org.codehaus.groovy.maven.runtime.support.stubgen.model.ModelFactorySupport.classDef(ModelFactorySupport.java:254)
      at org.codehaus.groovy.maven.runtime.support.stubgen.model.ModelFactorySupport.process(ModelFactorySupport.java:120)
      at org.codehaus.groovy.maven.runtime.support.stubgen.model.ModelFactorySupport.create(ModelFactorySupport.java:84)
      at org.codehaus.groovy.maven.runtime.v15.StubCompilerFeature$StubCompilerImpl.render(StubCompilerFeature.java:103)
      at org.codehaus.groovy.maven.runtime.v15.StubCompilerFeature$StubCompilerImpl.compile(StubCompilerFeature.java:92)
      at org.codehaus.groovy.maven.plugin.stubgen.AbstractGenerateStubsMojo.compile(AbstractGenerateStubsMojo.java:97)
      at org.codehaus.groovy.maven.plugin.stubgen.AbstractGenerateStubsMojo.process(AbstractGenerateStubsMojo.java:68)
      at org.codehaus.groovy.maven.plugin.ComponentMojoSupport.doExecute(ComponentMojoSupport.java:68)
      at org.codehaus.groovy.maven.plugin.MojoSupport.execute(MojoSupport.java:69)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:447)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:480)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:459)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:278)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)

      This worked with 1.0-rc3 about a week ago. Just grabbed the new snaps then bang.

      1. pom.xml
        15 kB
        Jason Dillon
      2. pom.xml
        15 kB
        Jason Dillon

        Activity

        Jason Dillon added a comment -

        Do you have a small project to share which causes this failure?

        Luke Daley added a comment -

        You can grab the project itself...

        http://svn.gldapo.codehaus.org/browse/gldapo/trunk

        But you will need to manually install an artifact to get it to build, instructions are at HAUS-1678

        mvn compile will show this error.

        Jason Dillon added a comment -

        I'm guessing you mean:

        http://svn.codehaus.org/gldapo/trunk/
        
        Jason Dillon added a comment -

        Looks like you need to add the codehaus snapshot repo/plugin-repo:

        http://snapshots.repository.codehaus.org

        As the snaps are defs there:

        http://snapshots.repository.codehaus.org/org/codehaus/groovy/maven/gmaven-plugin/1.0-rc-3-SNAPSHOT

        But seems like the metadata might have gotten munged... will try to sort that out.

        Jason Dillon added a comment -

        I take the last bit back, seems like the metadata is okay. I nuked my local repository and augmented your pom.xml to include the snapshot repos, and removed the extentions==true for gmaven-plugin (why did you set that up like that?) and it seems to build just fine. I'll attache the full pom that I built with (mvn test).

        Jason Dillon added a comment -

        Appears that you were just missing the SNAPSHOT repos.

        Luke Daley added a comment -

        I have the snapshot repos defined in my ~/.m2/settings.xml

        I'll try rm'ing all the gmaven stuff in my local repo and building.

        Luke Daley added a comment -

        Confirmed, my sincere apologies. I didn't have the profile active that defines the snapshot repo in my settings.xml. I still had to delete my gmaven stuff in my local repo though, I don't know why.

        Jason Dillon added a comment -

        Kay, I am going to proceed with the release today.


          People

          • Assignee:
            Jason Dillon
            Reporter:
            Luke Daley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: