GMaven (OLD... DO NOT USE)
  1. GMaven (OLD... DO NOT USE)
  2. MGROOVY-158

when checking out 1.0-rc2 from svn, operation failed with "can't move...permission denied'

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.0-rc-2
    • Fix Version/s: 1.0-rc-2
    • Component/s: build
    • Labels:
      None
    • Environment:
      checkout using svn
    • Number of attachments :
      0

      Description

      checkout fails with
      ...
      A gmaven-1.0-rc-2/gmaven-runtime/gmaven-runtime-1.0/src/main/java/org/codehaus/groovy/maven/runtime/v10/ConsoleFeature.java
      svn: Can't move 'gmaven-1.0-rc-2/gmaven-runtime/gmaven-runtime-1.0/src/main/java/org/.svn/tmp/entries' to 'gmaven-1.0-rc-2/gmaven-runtime/gmaven-runtime-1.0/src/main/java/org/.svn/entries': Permission denied

        Activity

        Ed Young added a comment -

        This happens only from a windows command line or a cygwin prompt. Checking out using tortoise svn or in linux works.

        Ed Young added a comment -

        Since I can check out using other methods it must be a problem related to running from the command line.

        Jason Dillon added a comment -

        Could be a problem of filename/path lengths on windows.


          People

          • Assignee:
            Jason Dillon
            Reporter:
            Ed Young
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: