GMaven (OLD... DO NOT USE)
  1. GMaven (OLD... DO NOT USE)
  2. MGROOVY-138

Stub generation fails if constructor calls super with a string arg containing '{'

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-rc-2
    • Fix Version/s: 1.0-rc-3
    • Component/s: stub generation
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Produces error 'Unexpected node: Node[29:15,47,STRING_CONSTRUCTOR]'

        Issue Links

          Activity

          Jason Dillon added a comment -

          I'm having trouble reproducing this, do you have a code example which fails?

          Luke Daley added a comment -

          My bad, it bails when there is a GString in the string. Just a '{' by itself doesn't produce it. Project that fails attached.

          Jason Dillon added a comment -

          Aighty, looks like GStrings produce different node types... I'm gonna add some muck to cast to (String)null and hope that works. Can you test if it works for you please? New 1.0-rc-3-SNAPSHOT artifacts should be out shortly with the fix.

          Jason Dillon added a comment -

          Believe this is fixed

          Luke Daley added a comment -

          1.0-rc-3-SNAPSHOT fixes this issue, thanks.


            People

            • Assignee:
              Jason Dillon
              Reporter:
              Luke Daley
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: