Maven GPG Plugin
  1. Maven GPG Plugin
  2. MGPG-28

Should be able to use gpg2 that MacPorts will install

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      On Mac, should be able to use gpg2 or gpg.

      paul$ gpg --version
      gpg (GnuPG) 1.4.10
      Copyright (C) 2008 Free Software Foundation, Inc.

      paul$ gpg2 --version
      gpg (GnuPG) 2.0.13
      libgcrypt 1.4.4
      Copyright (C) 2009 Free Software Foundation, Inc.

        Issue Links

          Activity

          Show
          Benjamin Bentmann added a comment - Why can't you set https://maven.apache.org/plugins/maven-gpg-plugin/sign-mojo.html#executable to "gpg2"?
          Hide
          Benjamin Bentmann added a comment -

          Use -Dgpg.executable=gpg or -Dgpg.executable=gpg2.

          Show
          Benjamin Bentmann added a comment - Use -Dgpg.executable=gpg or -Dgpg.executable=gpg2 .

            People

            • Assignee:
              Benjamin Bentmann
              Reporter:
              Paul Hammant
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: