Mojo's FindBugs Maven Plugin
  1. Mojo's FindBugs Maven Plugin
  2. MFINDBUGS-100

Build failure with findbugs-plugin:2.2, maven-3.0-alpha-4 and when localRepository is setted in settings.xml when you do site:site

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.3
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Build failure with findbugs-plugin:2.2, maven-3.0-alpha-4 and when a localRepository is setted in settings.xml when you do site:site.

      The error is

      [INFO] — findbugs-maven-plugin:2.2:findbugs (verify_findbugs) @ frontools-parent —
      [DEBUG] While downloading xml-apis:xml-apis:2.0.2
      This artifact has been relocated to xml-apis:xml-apis:1.0.b2.

      [DEBUG] Created new class realm plugin>org.codehaus.mojo:findbugs-maven-plugin:2.2
      [DEBUG] Populating plugin realm for org.codehaus.mojo:findbugs-maven-plugin:2.2
      [DEBUG] Included: org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:2.2
      [DEBUG] Included: org.apache.maven.reporting:maven-reporting-impl:jar:2.0
      [DEBUG] Excluded: org.apache.maven:maven-project:jar:2.0
      [DEBUG] Excluded: org.apache.maven:maven-profile:jar:2.0
      [DEBUG] Excluded: org.apache.maven:maven-model:jar:2.0.2
      [DEBUG] Included: org.codehaus.plexus:plexus-utils:jar:1.5.1
      [DEBUG] Excluded: org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9
      [DEBUG] Excluded: classworlds:classworlds:jar:1.1-alpha-2
      [DEBUG] Excluded: org.apache.maven:maven-artifact-manager:jar:2.0.2
      [DEBUG] Excluded: org.apache.maven:maven-repository-metadata:jar:2.0.2
      [DEBUG] Excluded: org.apache.maven:maven-artifact:jar:2.0.2
      [DEBUG] Excluded: org.apache.maven.wagon:wagon-provider-api:jar:1.0-alpha-6
      [DEBUG] Included: commons-validator:commons-validator:jar:1.1.4
      [DEBUG] Excluded: org.apache.maven:maven-plugin-api:jar:2.0
      [DEBUG] Included: oro:oro:jar:2.0.7
      [DEBUG] Included: org.apache.maven.reporting:maven-reporting-api:jar:2.0.8
      [DEBUG] Included: doxia:doxia-core:jar:1.0-alpha-4
      [DEBUG] Included: org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-9
      [DEBUG] Included: org.apache.maven.shared:maven-doxia-tools:jar:1.0
      [DEBUG] Included: commons-io:commons-io:jar:1.4
      [DEBUG] Included: org.apache.maven.doxia:doxia-decoration-model:jar:1.0-alpha-11
      [DEBUG] Included: org.codehaus.plexus:plexus-i18n:jar:1.0-beta-7
      [DEBUG] Included: com.google.code.findbugs:findbugs-ant:jar:1.3.9
      [DEBUG] Included: com.google.code.findbugs:findbugs:jar:1.3.9
      [DEBUG] Included: com.google.code.findbugs:bcel:jar:1.3.9
      [DEBUG] Included: com.google.code.findbugs:jsr305:jar:1.3.9
      [DEBUG] Included: com.google.code.findbugs:jFormatString:jar:1.3.9
      [DEBUG] Included: com.google.code.findbugs:annotations:jar:1.3.9
      [DEBUG] Included: dom4j:dom4j:jar:1.6.1
      [DEBUG] Included: xml-apis:xml-apis:jar:1.0.b2
      [DEBUG] Included: jaxen:jaxen:jar:1.1.1
      [DEBUG] Included: jdom:jdom:jar:1.0
      [DEBUG] Included: xerces:xercesImpl:jar:2.6.2
      [DEBUG] Included: xom:xom:jar:1.0
      [DEBUG] Included: xerces:xmlParserAPIs:jar:2.6.2
      [DEBUG] Included: xalan:xalan:jar:2.6.0
      [DEBUG] Included: com.ibm.icu:icu4j:jar:2.6.1
      [DEBUG] Included: asm:asm:jar:3.1
      [DEBUG] Included: asm:asm-analysis:jar:3.1
      [DEBUG] Included: asm:asm-tree:jar:3.1
      [DEBUG] Included: asm:asm-commons:jar:3.1
      [DEBUG] Included: asm:asm-util:jar:3.1
      [DEBUG] Included: asm:asm-xml:jar:3.1
      [DEBUG] Included: commons-lang:commons-lang:jar:2.4
      [DEBUG] Included: jgoodies:plastic:jar:1.2.0
      [DEBUG] Included: org.codehaus.groovy.maven:gmaven-mojo:jar:1.0-rc-3
      [DEBUG] Included: org.codehaus.groovy.maven.runtime:gmaven-runtime-api:jar:1.0-rc-3
      [DEBUG] Included: org.codehaus.groovy.maven.feature:gmaven-feature-api:jar:1.0-rc-3
      [DEBUG] Included: org.codehaus.groovy.maven.runtime:gmaven-runtime-default:jar:1.0-rc-3
      [DEBUG] Included: org.slf4j:slf4j-api:jar:1.5.0
      [DEBUG] Included: org.codehaus.groovy.maven.runtime:gmaven-runtime-1.5:jar:1.0-rc-3
      [DEBUG] Included: org.codehaus.groovy.maven.feature:gmaven-feature-support:jar:1.0-rc-3
      [DEBUG] Included: org.codehaus.groovy.maven.runtime:gmaven-runtime-support:jar:1.0-rc-3
      [DEBUG] Included: org.codehaus.groovy.maven:gmaven-common:jar:1.0-rc-3
      [DEBUG] Included: com.thoughtworks.qdox:qdox:jar:1.6.3
      [DEBUG] Included: org.codehaus.groovy:groovy-all-minimal:jar:1.5.6
      [DEBUG] Included: org.apache.ant:ant:jar:1.7.1
      [DEBUG] Included: org.apache.ant:ant-launcher:jar:1.7.1
      [DEBUG] Included: jline:jline:jar:0.9.94
      [DEBUG] Included: org.codehaus.plexus:plexus-resources:jar:1.0-alpha-4
      [DEBUG] Configuring mojo 'org.codehaus.mojo:findbugs-maven-plugin:2.2:findbugs' with basic configurator -->
      [DEBUG] (s) classFilesDirectory = C:\HOMEWARE\workspace\ARC-frontools-parent\target\classes
      [DEBUG] (s) compileSourceRoots = [C:\HOMEWARE\workspace\ARC-frontools-parent\src\main\java]
      [DEBUG] (s) debug = false
      [DEBUG] (s) failOnError = true
      [DEBUG] (s) findbugsXmlOutput = false
      [DEBUG] (s) findbugsXmlOutputDirectory = C:\HOMEWARE\workspace\ARC-frontools-parent\target
      [DEBUG] (s) includeTests = false
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 6.375s
      [INFO] Finished at: Thu Nov 26 20:42:37 CET 2009
      [INFO] Final Memory: 6M/12M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Unable to parse configuration of mojo org.codehaus.mojo:findbugs-maven-plugin:2.2:findbugs for parameter localRepository: Cannot assign configuration
      entry 'localRepository' to 'class org.apache.maven.artifact.repository.DefaultArtifactRepository' from '$

      {localRepository}', which is of type class org.apac
      he.maven.repository.DelegatingLocalArtifactRepository -> [Help 1]
      org.apache.maven.plugin.PluginConfigurationException: Unable to parse configuration of mojo org.codehaus.mojo:findbugs-maven-plugin:2.2:findbugs for paramete
      r localRepository: Cannot assign configuration entry 'localRepository' to 'class org.apache.maven.artifact.repository.DefaultArtifactRepository' from '${localRepository}

      ', which is of type class org.apache.maven.repository.DelegatingLocalArtifactRepository
      at org.apache.maven.plugin.internal.DefaultMavenPluginManager.populatePluginFields(DefaultMavenPluginManager.java:646)
      at org.apache.maven.plugin.internal.DefaultMavenPluginManager.getConfiguredMojo(DefaultMavenPluginManager.java:598)
      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:94)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:547)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:317)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:239)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:102)
      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:421)
      at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:156)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:121)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: org.codehaus.plexus.component.configurator.ComponentConfigurationException: Cannot assign configuration entry 'localRepository' to 'class org.apac
      he.maven.artifact.repository.DefaultArtifactRepository' from '$

      {localRepository}

      ', which is of type class org.apache.maven.repository.DelegatingLocalArtifact
      Repository
      at org.codehaus.plexus.component.configurator.converters.AbstractConfigurationConverter.fromExpression(AbstractConfigurationConverter.java:161)
      at org.codehaus.plexus.component.configurator.converters.composite.ObjectWithFieldsConverter.fromConfiguration(ObjectWithFieldsConverter.java:76)
      at org.codehaus.plexus.component.configurator.converters.ComponentValueSetter.configure(ComponentValueSetter.java:221)
      at org.codehaus.plexus.component.configurator.converters.composite.ObjectWithFieldsConverter.processConfiguration(ObjectWithFieldsConverter.java:145)

      at org.codehaus.plexus.component.configurator.BasicComponentConfigurator.configureComponent(BasicComponentConfigurator.java:58)
      at org.apache.maven.plugin.internal.DefaultMavenPluginManager.populatePluginFields(DefaultMavenPluginManager.java:633)
      ... 17 more
      [ERROR]
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginConfigurationException

        Issue Links

          Activity

          Michel Rasschaert added a comment -

          Have you tried with the 2.3-SNAPSHOT version of the plugin ?

          Alexandre Navarro added a comment -

          Hi Michel, not yet but I will. But it is not important yet because I'm just beginning to test maven 3 to correct all the things will be deprecated in maven 3.0 and know the different problems with my specific poms.

          Mirko Friedenhagen added a comment - - edited

          I have built 3.0-beta-1-SNAPSHOT of the maven-site-plugin from SVN, use Maven 3.0-alpha-5 and findbugs-plugin 2.3-SNAPSHOT and did remove localRepository in my .m2/settings.xml. However I get the same stacktrace when executing findbugs:findbugs:

          [ERROR] Failed to execute goal org.codehaus.mojo:findbugs-maven-plugin:2.3-SNAPSHOT:findbugs (default-cli) on project webdriverfirebug: Unable to parse configuration of mojo org.codehaus.mojo:findbugs-maven-plugin:2.3-SNAPSHOT:findbugs for parameter localRepository: Cannot assign configuration entry 'localRepository' to 'class org.apache.maven.artifact.repository.DefaultArtifactRepository' from '$

          {localRepository}', which is of type class org.apache.maven.repository.DelegatingLocalArtifactRepository -> [Help 1]
          org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:findbugs-maven-plugin:2.3-SNAPSHOT:findbugs (default-cli) on project webdriverfirebug: Unable to parse configuration of mojo org.codehaus.mojo:findbugs-maven-plugin:2.3-SNAPSHOT:findbugs for parameter localRepository: Cannot assign configuration entry 'localRepository' to 'class org.apache.maven.artifact.repository.DefaultArtifactRepository' from '${localRepository}

          ', which is of type class org.apache.maven.repository.DelegatingLocalArtifactRepository
          at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:574)
          at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:317)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:245)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:102)
          at org.apache.maven.cli.MavenCli.execute(MavenCli.java:423)
          at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:158)
          at org.apache.maven.cli.MavenCli.main(MavenCli.java:123)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
          at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
          at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
          Caused by: org.apache.maven.plugin.PluginConfigurationException: Unable to parse configuration of mojo org.codehaus.mojo:findbugs-maven-plugin:2.3-SNAPSHOT:findbugs for parameter localRepository: Cannot assign configuration entry 'localRepository' to 'class org.apache.maven.artifact.repository.DefaultArtifactRepository' from '$

          {localRepository}', which is of type class org.apache.maven.repository.DelegatingLocalArtifactRepository
          at org.apache.maven.plugin.internal.DefaultMavenPluginManager.populatePluginFields(DefaultMavenPluginManager.java:655)
          at org.apache.maven.plugin.internal.DefaultMavenPluginManager.getConfiguredMojo(DefaultMavenPluginManager.java:607)
          at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:94)
          at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:562)
          ... 14 more
          Caused by: org.codehaus.plexus.component.configurator.ComponentConfigurationException: Cannot assign configuration entry 'localRepository' to 'class org.apache.maven.artifact.repository.DefaultArtifactRepository' from '${localRepository}

          ', which is of type class org.apache.maven.repository.DelegatingLocalArtifactRepository
          at org.codehaus.plexus.component.configurator.converters.AbstractConfigurationConverter.fromExpression(AbstractConfigurationConverter.java:161)
          at org.codehaus.plexus.component.configurator.converters.composite.ObjectWithFieldsConverter.fromConfiguration(ObjectWithFieldsConverter.java:76)
          at org.codehaus.plexus.component.configurator.converters.ComponentValueSetter.configure(ComponentValueSetter.java:221)
          at org.codehaus.plexus.component.configurator.converters.composite.ObjectWithFieldsConverter.processConfiguration(ObjectWithFieldsConverter.java:145)
          at org.codehaus.plexus.component.configurator.BasicComponentConfigurator.configureComponent(BasicComponentConfigurator.java:58)
          at org.apache.maven.plugin.internal.DefaultMavenPluginManager.populatePluginFields(DefaultMavenPluginManager.java:642)
          ... 17 more

          Benjamin Bentmann added a comment -

          This is not a duplicate of MFINDBUGS-94. The plugin's mojo is coded against implementation classes where it should have used interface instead. And the underlying implementation of the repository system in Maven 3 has changed.

          Benjamin Bentmann added a comment -

          The plugin is currently being voted on for release so I attach the fix as a patch to not disturb the process though I hope the release manager will consider its inclusion.

          Garvin LeClaire added a comment -

          I will try to get it in for this release. I may just extend the vote. If needed, I can reissue a vote request.

          Garvin


            People

            • Assignee:
              Garvin LeClaire
              Reporter:
              Alexandre Navarro
            • Votes:
              8 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: