mevenide
  1. mevenide
  2. MEVENIDE-435

cannot debug tests when surefire's argLine paramter used in pom

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: NB_2.1.1
    • Fix Version/s: NB_2.4
    • Component/s: mevenide2-netbeans
    • Labels:
      None
    • Number of attachments :
      2

      Description

      the debug switches are passed to the surefire plugin via the -DargLine=-Xdebug...... property.
      However when user defines the argLine parameter for surefire plugin in the pom, the system property is not being evaluated.

      There's currently no solution to the problem. One idea that needs some prottyping is to add a method to the embedder that would be able to run the build on top of MavenProject instance instead of a pom file. That we we could dynamically inject the additional debug switches dynamicaly when constructing the MavenProject instance.

        Activity

        Jeff Campbell added a comment -

        One additional side comment.... half of us that use NetBeans are using 6.5 Nightly with the MevenIDE 4.0.4 plugin and we are STILL seeing the same issue.

        Milos Kleint added a comment -

        Sure, it's not working in 6.5, as I mentioned earlier. I'll be switching to maven.surefire.debug property AFTER 6.5.
        So you either use the suggested workaround and will have to live without debugging tests, sorry. Checking the nbactions.xml file (with custom action mappings in netbeans) has no effect whatsoever on eclipse or idea users.

        Milos Kleint added a comment -
        Jaromir Uhrik added a comment -

        This bug was transferred to the NetBeans Issuezilla bug tracking system as http://www.netbeans.org/issues/show_bug.cgi?id=154477

        Milos Kleint added a comment -

        closing the issue as duplicate of the newly created one in netbeans.org issuezilla.
        Please post your additional comments to the new issue.


          People

          • Assignee:
            Milos Kleint
            Reporter:
            Milos Kleint
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: