Maven Enforcer Plugin
  1. Maven Enforcer Plugin
  2. MENFORCER-128

Fail the build if a dependency is overwriten with an incompatible lower version (patch)

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1
    • Component/s: Standard Rules
    • Labels:
      None
    • Testcase included:
      yes
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      Overwriting a dependency to a lower version than any of your other dependencies need should fail the build if this new enforcer rule is active.

      For example, this is bad:

      
        <dependencies>
          <dependency>
            <groupId>org.slf4j</groupId>
            <artifactId>slf4j-api</artifactId>
            <version>1.4.0</version>
          </dependency>
          <dependency>
            <groupId>ch.qos.logback</groupId>
            <artifactId>logback-classic</artifactId>
            <version>0.9.9</version>
            <!-- Depends on org.slf4j:slf4j-api:1.5.0 -->
          </dependency>
        </dependencies>
      

      Attaching patch in a few minutes.

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Paul Gier
            Reporter:
            Geoffrey De Smet
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: