Maven Eclipse Plugin
  1. Maven Eclipse Plugin
  2. MECLIPSE-602

OSGI Spec allow multiple versions of the same plugin within an installtion. to-maven mojo cannot deal with situations like that

    Details

    • Type: Bug Bug
    • Status: Open Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: 2.7
    • Fix Version/s: None
    • Component/s: PDE support
    • Labels:
      None
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      I have noticed this when I was working on the issue:
      http://jira.codehaus.org/browse/MECLIPSE-601

      It looks like that if you have multiple versions of the same plugin, only one of them can be installed as the plugins and models maps are used with the groupId.artifactId as the key.
      So a subsequent version of the same plugin will replace the previous one leading to the last-one-wins situation.

      This might look an innocent bug however image you have two set of plugins in your installation. Then you will end up a randomly -picked list of a single entry list of the plugins in your repository that can possibly lead to unwanted version chaos. Furthermore this situation can be missed easily and can cause a big headache to the experiencing person.

      Attached path resolves the issue...

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Hasan Ceylan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: