Maven Eclipse Plugin
  1. Maven Eclipse Plugin
  2. MECLIPSE-531

eclipse:to-maven uses version ranges in pom.xmls created, which fail version checking

    Details

    • Type: Improvement Improvement
    • Status: Open Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 2.5.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP SP3, Maven 2.0.9, Java 1.6.0.11
    • Number of attachments :
      0

      Description

      If you use eclipse:to-maven, the resulting artifacts have poms containing versions like these, for dependencies: [3.2.0,4.0.0).

      End result =>

      Couldn't find a version in [3.2.0-v3232o] to match range [3.2.0,4.0.0)

      I believe that to-maven needs an option like make-artifacts, to resolveVersionRanges, because stripping qualifiers means that we lose information (Eclipse 3.4 has some 3.2.0 plugins for example, but with a different qualifier than the original 3.2 Eclipse plugins).

      Or the version ranges need to be fixed, something like this: [3.2.0-, 4.0.0-).

      Thank you.

        Activity

        No changes have yet been made on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Costin Caraivan
          • Votes:
            4 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: