Maven Eclipse Plugin
  1. Maven Eclipse Plugin
  2. MECLIPSE-206

IdeUtils.toRelativeAndFixSeparator broken on Windows

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.6
    • Labels:
      None
    • Environment:
      Windows XP
    • Number of attachments :
      1

      Description

      See http://www.nabble.com/forum/ViewPost.jtp?post=7753417&framed=y&skin=177

      The problem is that IdeUtils.toRelativeAndFixSeparator attempts to canonicalise relative paths.
      This will cause the result to be based on the current directory of the processor and not the project basedir as intended.
      This causes the build to fail with canonicalisation errors.

      I have supplied a patch against r485327 which includes extra test cases and all test cases pass.

      I have also:

      • removed the project
      • removed use of assertTrue and converted to assertEquals (tests were succeeding when they should not have because the check was on the trailing path not the entire path)
      • removed MavenProject from extractResourceDirs (it was never used)

      Some other comments:
      baseDir and projectBaseDir seem to be used but I can not see any use cases where these two are not the same value. Shouldn't the pom file always be located at the top of the eclipse project workspace? The similar names and mostly the same value caused me trouble in understanding the system. If they could get removed it would make things easier.

        Activity

        Barrie Treloar added a comment -

        This is generated via eclipse so you will probably need the -pX command to get it to work, as -p0 is the full path to my ide workspace.

        Barrie Treloar added a comment -

        Already has been fixed.

        Added in unit tests to IdeUtilsTest.


          People

          • Assignee:
            Barrie Treloar
            Reporter:
            Barrie Treloar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: