Maven Eclipse Plugin
  1. Maven Eclipse Plugin
  2. MECLIPSE-174

Plugin doesn't cache "source not available" status

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.3
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      When the m2 plugin reads the POM files and "Download sources" is set in the Eclipse preferences, it tries to download the source every time.

      Instead, it should cache the "source not available" status somewhere (just like Maven itself does) and not print thousands of error messages (Unable to download the artifact from any repository).

      This also delays the build considerably (opening network connections) and real errors are drowned.

        Issue Links

          Activity

          fabrizio giustina added a comment -

          scheduling for 2.3

          fabrizio giustina added a comment -

          in svn for 2.3: status cache is kept in project target dir, multiproject builds never check for the same artfacts twice

          Aaron Digulla added a comment -

          Can't you reuse the standard maven2 cache? I would prefer if the command line maven and the plugin would agree on what has been tried and what hasn't.

          Also I don't think the target dir is a good place for this information. What happens when I close a project? Why not put this into the workspace instead?

          Chuck Daniels added a comment - - edited

          Looks like this has regressed in version 2.4 of this plugin. The mvn-eclipse-cache.properties file is empty (except for header comment) after running eclipse:eclipse with downloadSources and downloadJavadocs set to true. Now every run of eclipse:eclipse attempts to download sources and javadocs since cache file contains no entries.

          Aaron Digulla added a comment -

          I can confirm that. It seems the list of downloaded files which you get back from resolveArtifacts() (from memory; I'm not at my work PC right now) is empty.


            People

            • Assignee:
              fabrizio giustina
              Reporter:
              Aaron Digulla
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: