Maven Deploy Plugin
  1. Maven Deploy Plugin
  2. MDEPLOY-70

remove copy of plexus-utils' XML encoding support sources

    Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.5
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      need to upgrade prerequisite to Maven 2.0.6
      see http://docs.codehaus.org/display/MAVENUSER/XML+encoding

        Issue Links

          Activity

          Hide
          Olivier Lamy added a comment -

          Oh yes please do it !
          some much line of codes to copy when fixing an issue in p-u !

          Show
          Olivier Lamy added a comment - Oh yes please do it ! some much line of codes to copy when fixing an issue in p-u !
          Hide
          Herve Boutemy added a comment -

          yes, it will be a Good Thing (TM) when they are removed
          But as discussed before on the dev mailing list, this would require upgrading prerequisite to Maven 2.0.6, which is not wanted for now

          Now, please don't over-react: "only" XML encoding related classes are copied, which I'm maintaining and don't change much.
          Today was the first change in 6 months, and yes, I had to copy the change to 4 components: it was a known compromise, I assume it and did the changes.
          This time, I created corresponding issues in Jira to track it, and made links in the Wiki entry, so that everything is tracked as much as possible.

          If you convince everybody to upgrade Maven prerequisite to 2.0.6 for one of the 4 plugins, I'll be the first to drop the copy

          Show
          Herve Boutemy added a comment - yes, it will be a Good Thing (TM) when they are removed But as discussed before on the dev mailing list, this would require upgrading prerequisite to Maven 2.0.6, which is not wanted for now Now, please don't over-react: "only" XML encoding related classes are copied, which I'm maintaining and don't change much. Today was the first change in 6 months, and yes, I had to copy the change to 4 components: it was a known compromise, I assume it and did the changes. This time, I created corresponding issues in Jira to track it, and made links in the Wiki entry, so that everything is tracked as much as possible. If you convince everybody to upgrade Maven prerequisite to 2.0.6 for one of the 4 plugins, I'll be the first to drop the copy
          Hide
          Olivier Lamy added a comment -

          2.0.6 is 9 months old.
          And 2.0.8 has fixed some issues introduced in 2.0.6/2.0.7.
          I think users has migrated to 2.0.8. If not lock the plugin version in a pom is a solution.
          And it's not an over-react .
          FYI the next maven-jar-plugin will use last p-u -> 2.0.6 prerequisite.

          Show
          Olivier Lamy added a comment - 2.0.6 is 9 months old. And 2.0.8 has fixed some issues introduced in 2.0.6/2.0.7. I think users has migrated to 2.0.8. If not lock the plugin version in a pom is a solution. And it's not an over-react . FYI the next maven-jar-plugin will use last p-u -> 2.0.6 prerequisite.
          Hide
          Herve Boutemy added a comment -

          I understand your arguments.
          IMHO, users who did not migrate are precisely those who won't be able to lock the plugin version: they'll say that "Maven doesn't work", and we'll have to convince them that not specifying plugin version was a bad habit...
          On the other hand, having these XML encoding support classes copied in 4 components is not so hard for me to maintain: 1 line change in 6 months. And I don't think there will be more change in next months. MSITE-242 has more sources copied (cli, interpolation and introspection): perhaps these classes are more like a problem.

          Really, now that the compromise is tracked in these 4 Jira issues to be sure it's not forgotten, I think we don't need to hurry: time is our friend.

          Personally, I don't think changing prerequisite is a good idea before next release of install, deploy and release plugins since last releases are a bit old.
          For each plugin, when the next release is out, perhaps it will be the good time to look at this issue.

          Show
          Herve Boutemy added a comment - I understand your arguments. IMHO, users who did not migrate are precisely those who won't be able to lock the plugin version: they'll say that "Maven doesn't work", and we'll have to convince them that not specifying plugin version was a bad habit... On the other hand, having these XML encoding support classes copied in 4 components is not so hard for me to maintain: 1 line change in 6 months. And I don't think there will be more change in next months. MSITE-242 has more sources copied (cli, interpolation and introspection): perhaps these classes are more like a problem. Really, now that the compromise is tracked in these 4 Jira issues to be sure it's not forgotten, I think we don't need to hurry: time is our friend. Personally, I don't think changing prerequisite is a good idea before next release of install, deploy and release plugins since last releases are a bit old. For each plugin, when the next release is out, perhaps it will be the good time to look at this issue.
          Hide
          Olivier Lamy added a comment -

          fixed in rev 684331.

          Show
          Olivier Lamy added a comment - fixed in rev 684331.

            People

            • Assignee:
              Olivier Lamy
              Reporter:
              Herve Boutemy
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: