Maven Deploy Plugin
  1. Maven Deploy Plugin
  2. MDEPLOY-43

Deploy plugin does not consider artifact type when deploying snapshots

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      all environments
    • Number of attachments :
      0

      Description

      A single artifact with multiple components is not handled properly.

      Deploying a single snapshot artifact that has multiple components such as a native component with an so/dll file and a matching lib file results in two different id's while only the last id is recorded in the meta data.

      Of course, this means that the first file can not be resolve.

      The deploy plugin should take the file type into account when deploying the artifact so that multiple components of an artifact have the same snapshot id.

      To test the issue, use the native-maven-plugin (http://mojo.codehaus.org/maven-native/native-maven-plugin/index.html) to deploy an artifact as a snapshot version.
      Once deployed inspect the repository; You should find an so/dll and a lib with two different snapshot ids and the maven-metadata.xml will contain the id of the last file that was actually copied (in this case the lib file).

        Issue Links

          Activity

          Abraham Swanepoel added a comment -

          We ran into this issue while trying to deploy several snapshot components (jar, source and others) from an external source to our local Maven repository. We have to run mvn deploy:deploy-file on each component and each time it runs the version number gets bumped. Only the last component can be reolved. One work-around is to specify -DuniqueVersion=false but this is not an acceptable solution in all cases.

          Brill Pappin added a comment -

          This issue was submitted in 2006 and marked "Critical"... but it's not even assigned!
          I don't hold out much hope that the developers of this plugin are paying attention.

          I'd guess the way to get it fixed is for someone to submit a patch and hope that there is someone around who can apply it.

          Paul Gier added a comment -

          MDEPLOY-48 allows the deploy-file mojo to deploy sources and javadoc along with the main project artifact. I realize this doesn't handle all cases where you want to manually deploy multiple snapshot files. For these cases, you might try the Maven Ant tasks which allow any number of files to be attached to a single deployment.

          http://maven.apache.org/ant-tasks/reference.html#install

          Stephen Connolly added a comment -

          MDEPLOY-137 solves this issue

          Brill Pappin added a comment -

          Closed as a duplicate, but a duplicate of which issue?
          Please include the link to the primary issue being worked on, or I'll simply reopen this issue.


            People

            • Assignee:
              Unassigned
              Reporter:
              Brill Pappin
            • Votes:
              3 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: