Maven Compiler Plugin
  1. Maven Compiler Plugin
  2. MCOMPILER-99

Spaces in for external executable are not accepted

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.4
    • Labels:
      None
    • Environment:
      Windows XP
    • Number of attachments :
      0

      Description

      When the path to the external executable in <executable> contains space(s), the build will fail: the command is misunderstood because it stops at the first space encountered.

      Example:
      <executable>C:\Program Files\java\jdk1.6.0_11\bin\javac.exe</executable>
      The plugin will try to execute "C:\Program" instead.

      On windows the only workaround I know of is:
      <executable>C:\PROGRA~1\java\jdk1.6.0_11\bin\javac.exe</executable>

        Activity

        Robert Scholte added a comment -

        Could someone verify if this is still a problem? With Windows7 I'm not able to reproduce this issue.
        The problem should be caused by the plexus-compiler. Meanwhile we've already updated its version from 1.6 (used by maven-compiler-plugin-2.1) to 1.8.2. Strange enough Plexus' Jira doesn't refer to such an issue.

        Olivier Lamy added a comment -

        tested on osx


          People

          • Assignee:
            Olivier Lamy
            Reporter:
            Jean-Marc Borer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: