Maven Compiler Plugin
  1. Maven Compiler Plugin
  2. MCOMPILER-183

Maven on JDK 7 can't compile classes with UTF-8 characters in the name.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      I have created a project on Github that reproduces and explains the exact issue.

      https://github.com/aslakhellesoy/maven-utf8-jdk7-woes

        Activity

        Aslak Helles°y added a comment -

        Turns out this is an OS X issue and not a Maven issue. Everything works fine on Linux. I'm closing this.

        Aslak Helles°y added a comment -

        See updated details of my findings in the Github project.


          People

          • Assignee:
            Unassigned
            Reporter:
            Aslak Helles°y
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: