Maven Compiler Plugin
  1. Maven Compiler Plugin
  2. MCOMPILER-10

display summary information including number of compiler errors when compiler plugin fails.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Labels:
      None
    • Number of attachments :
      2
    1. logExample.bmp
      807 kB
      yair567
    2. patch.txt
      0.8 kB
      Thomas Hart

      Activity

      yair567 added a comment -

      HI evry one
      I tried to send mail to the mailing list but i got an eror
      so here is my question

      I new to maven

      I try integration between eclipse and maven with my little project example but I got a Compilation error

      The problem is that it not tell me what is the problem

      These is what I got

      [INFO] ----------------------------------------------------------------------------

      [INFO] Building Unnamed - logging:logging:jar:0.0.1

      [INFO] task-segment: [package]

      [INFO] ----------------------------------------------------------------------------

      [INFO] resources:resources

      [INFO] Using default encoding to copy filtered resources.

      [INFO] compiler:compile

      [INFO] Compiling 3 source files to D:\ladpc\workspaces\ladpcApp\logging\target\classes

      [ERROR] mojo-execute : compiler:compile

      Diagnosis: Compilation failure

      FATAL ERROR: Error executing Maven for a project

      [ERROR] project-execute : logging:logging:jar:0.0.1 ( task-segment: [package] )

      Diagnosis: Compilation failure

      FATAL ERROR: Error executing Maven for a project

      org.apache.maven.BuildFailureException: Compilation failure

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:555)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:475)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:454)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:306)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:273)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:140)

      at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedder.java:441)

      at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedder.java:382)

      at org.maven.ide.eclipse.Maven2Executor.main(Maven2Executor.java:68)

      Caused by: org.apache.maven.plugin.CompilationFailureException: Compilation failure

      at org.apache.maven.plugin.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:516)

      at org.apache.maven.plugin.CompilerMojo.execute(CompilerMojo.java:114)

      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:412)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:534)

      ... 8 more

      But what is the problem?

      Here is my project tree

      Thank you all

      Yair

      Thomas Hart added a comment -

      I had the same problem in the Maven Integration Plugin for Eclipse. The attached patch shows the compile error messages to the eclipse console. I don't know if this the right issue but it works for me.

      Milos Kleint added a comment -

      maybe something wrong with the eclipse embedder code? I'm getting this compilation output when running within netbeans.

      [compiler:compile]
      Compiling 5 source files to /home/mkleint/src/mevenide/mevenide2/netbeans/webframeworks/target/classes
      ------------------------------------------------------------------------
      [ERROR]BUILD FAILURE
      ------------------------------------------------------------------------
      Compilation failure

      org/codehaus/mevenide/webframeworks/PanelSupportedFrameworksVisual.java.java:[376,39] cannot find symbol
      symbol : variable JAVA_EE_SPEC_50_LABEL
      location: class org.codehaus.mevenide.webframeworks.PanelSupportedFrameworksVisual

      org/codehaus/mevenide/webframeworks/PanelSupportedFrameworksVisual.java.java:[379,39] cannot find symbol
      symbol : variable J2EE_SPEC_14_LABEL
      location: class org.codehaus.mevenide.webframeworks.PanelSupportedFrameworksVisual

      org/codehaus/mevenide/webframeworks/PanelSupportedFrameworksVisual.java.java:[382,39] cannot find symbol
      symbol : variable J2EE_SPEC_13_LABEL
      location: class org.codehaus.mevenide.webframeworks.PanelSupportedFrameworksVisual
      ------------------------------------------------------------------------
      Total time: 25 seconds
      Finished at: Fri Nov 09 12:29:05 CET 2007
      Final Memory: 130M/254M
      ------------------------------------------------------------------------

      Ron Wheeler added a comment -

      It would seem that this is something everyone needs fixed and the fix is so small, it is hard to understand why it is not resolved at this time.
      What is the hang-up?
      Is there any disagreement about the severity, the nature of the problem or the applicability or robustness of the patch provided?

      Olivier Lamy added a comment -

      fixed in rev 616544.


        People

        • Assignee:
          Olivier Lamy
          Reporter:
          John Casey
        • Votes:
          32 Vote for this issue
          Watchers:
          16 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: