Mojo's Cobertura Maven Plugin
  1. Mojo's Cobertura Maven Plugin
  2. MCOBERTURA-114

Instrumenting Deployment Artifacts (major site doc enhancement and small plugin enhancement)

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.5
    • Labels:
      None
    • Environment:
      any
    • Testcase included:
      yes
    • Patch Submitted:
      Yes
    • Number of attachments :
      3

      Description

      It is occasionally useful to measure the code coverage for manual and/or
      automated tests which run against a test environment.(Not to be confused with
      measuring code coverage of unit tests executed automatically by the
      build system.) For example, you may have a set of automated regression
      tests written using JMeter, Selenium, etc. which for some reason or
      another are not appropriate to run as part of the maven build.

      The primary difficulty in supporting the above use case is understanding
      what needs done, and then to a limited extent configuring Maven appropriately.
      To that end I have added a new "Instrumenting a Deployment Artifact" section
      to the Maven Cobertura plugin's site documentation. I have attached a PDF
      showing the html rendered version of the enhanced documentation
      (source documentation file is in the usual apt format).

      In addition to the documentation enhancements, I have extended the instrument goal
      to support registering a module's cobertura.ser file as an attached artifact.
      This turns out to significantly clean up the child modules of a multi-module
      project, which would otherwise be cluttered with build-helper plugin configuration
      details.

      The attached patch file contains all of my changes. I look forward to a
      release in the near future which contains these changes, provided they
      are deemed acceptable by the project maintainers.

      1. additionalMavenDocs.pdf
        101 kB
        James Carpenter
      2. CoberturaDiagrams.pdf
        2.41 MB
        James Carpenter
      3. deploymentArtifactInstrumentation.patch
        33 kB
        James Carpenter

        Activity

        James Carpenter added a comment -

        I have also included some scans of hand-drawn diagrams I drew to complement the text.
        The documentation text in the patch does not currently link to or otherwise include the hand-drawn diagrams. I created
        the hand-drawn diagrams for use inside my company after I had finished creating the patch.

        Benson Margulies added a comment -

        I applied this patch and the test fails with an NPE. If you're out there, can you have a look? I'm going to see if I can fix it.

        Benson Margulies added a comment -

        Oh, I had a patch .rej, it's OK Now.

        Benson Margulies added a comment -

        fixed in 13886.

        Benson Margulies made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Benson Margulies [ bmargulies ]
        Fix Version/s 2.5 [ 16413 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Benson Margulies
            Reporter:
            James Carpenter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: