Maven Changes Plugin
  1. Maven Changes Plugin
  2. MCHANGES-282

New parameter releaseDateLocale in changes-check goal

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7.1
    • Fix Version/s: 2.10
    • Component/s: changes.xml
    • Labels:
      None
    • Environment:
    • Testcase included:
      yes
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      I have defined parameter

      releaseDateFormat=E MMM dd yyyy

      and release dates are defined with English locale in changes.xml.
      If I run maven with other locale settings, then changes-check goal failed that release date has wrong format.
      Workaround for this behaivour is, defines english locale in

      MAVEN_OPTS=-Duser.language=en -Duser.region=US

      , but better is define locale in configuration.

      <configuration>
        <releaseDateLocale>en_US</releaseDateLocale>
      </configuration>

        Activity

        Petr Prochazka added a comment -

        Patch + unit test changes.

        Michael Osipov added a comment -

        Use ISO 8601 and your pain will go away.

        Petr Prochazka added a comment -

        I can not change to ISO standard. I generate from changes RPM changelog where format of release date is in format above.

        Michael Osipov added a comment -

        Are you able to file a bug to fix the root cause rather than having a workaround in this plugin?

        Dennis Lundberg added a comment -

        The patch was applied in r1585646.

        I modified the patch so that there is no default value for the new parameter. This better mimics the old behavior. If you need a locale then you specify the parameter, otherwise you get the system's default locale.


          People

          • Assignee:
            Dennis Lundberg
            Reporter:
            Petr Prochazka
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: