Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Not A Bug
    • Affects Version/s: 2.4
    • Fix Version/s: None
    • Component/s: changes.xml
    • Labels:
      None
    • Number of attachments :
      2

      Description

      Sorry, i don't get it.
      i try to add/config my own tracking system.

      <issueManagement>
      <system>testtesttest</system>
      <url>http://somehost.com/project/dashboard</url>
      </issueManagement>

      but i cant use the %URL%, i specify this absolute in the plugin section.

      <configuration>
      <issueLinkTemplatePerSystem>
      <testtesttest>http://somehost.com/items?query=%ISSUE%</testtesttest>
      </issueLinkTemplatePerSystem>
      </configuration>

      in my changes.xml, the system is also testtesttest.
      Tried everything, but i dont get links.

      if i use

      <issueLinkTemplate>http://somehost.com/items?query=%ISSUE%</issueLinkTemplate>

      and "default" in changes.xml i DO get links, but always with the default value (regardless whats specified)

      [DEBUG] (f) issueLinkTemplate = %URL%/ViewIssue.jspa?key=%ISSUE%

      if i specify f. ex. "SourceForge" in changes.xml, the links work out-of-the-box

      tried also old suggestions like MCHANGES-166 - no success.

        Activity

        Dennis Lundberg added a comment -

        Hi

        Make sure that you are configuring the plugin in the reporting section of the POM.

        I took your configuration snippets and put them into a sample project that works fine for me. I get the custom links both for actions that don't have a system specified and when the system is testtesttest. I'll attach it to this issue.

        Dennis Lundberg added a comment -

        Sample project that works for me.

        Myron added a comment -

        Thanks for the sample - it does not work for me.
        Page looks fine, but there are no links to the issue tracker....

        i'm using maven3, might this be a problem?!

        M:\dev\test>mvn -version
        Apache Maven 3.0.2 (r1056850; 2011-01-09 01:58:10+0100)
        Java version: 1.6.0_22, vendor: Sun Microsystems Inc.
        Java home: D:\Programme\Java\jdk6\jre
        Default locale: de_AT, platform encoding: Cp1252
        OS name: "windows xp", version: "5.1", arch: "x86", family: "windows"

        Dennis Lundberg added a comment -

        Well, that's what the environment text field in JIRA if for...

        Reporting plugins, like the Changes Plugin, are not configured in the same way in Maven 3 as they were in Maven2. Please read this about how to use the Site Plugin in Maven 3:
        https://cwiki.apache.org/MAVEN/maven-3x-and-site-plugin.html

        If you need configure a reporting plugin to be used without the Site Plugin, i.e 'mvn changes:changes-report' from the command line, then you need to configure the plugin in the <build> section of your POM, even though it is a reporting plugin.

        Dennis Lundberg added a comment -

        Updated POM with a profile for use with Maven 3.

        Myron added a comment -

        Thanks for your patience - it was a clear layer8 problem.
        It is working now with this sample, and i know what to do. (and what I've should have done)

        We recently switched to maven (2, then 3 shortly after) and i only checked the page till the compatibility matrix.
        All other reports i added worked "the old way", so it didn't come to my mind that my setup was that false for this plugin....
        lesson learned.


          People

          • Assignee:
            Dennis Lundberg
            Reporter:
            Myron
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: