Maven Changes Plugin
  1. Maven Changes Plugin
  2. MCHANGES-168

Jira Report (jira-report.html) scrambles encoding of Jira Issues when their summary is written in Non Latin Characters

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.6
    • Component/s: jira
    • Labels:
      None
    • Environment:
      mvn on Mac OS X 10.5.7
      Atlassian JIRA Enterprise Edition, Version: 3.13.2 on Ubuntu 8.04.2
    • Number of attachments :
      4

      Description

      My Jira Issues have Summaries in Jira in non-Lating characters (in Greek in our case).
      The plugin works great up to the point that it creates the jira-report.html (attached).
      The jira-results.xml seems to be in UTF-8 (also attached).
      If an XSL Stylesheet is used it does not seem to observe the rss data encoding of Jira Issues which works, by the way, fine win Non-Latin Characters with other rss clients.

      1. jira-report.html
        4 kB
        Vangelis Ghiossis
      2. jira-results.xml
        17 kB
        Vangelis Ghiossis
      3. pom.xml
        1 kB
        Vangelis Ghiossis
      1. Jira-Report-ScreenShot.jpg
        72 kB

        Issue Links

          Activity

          Vangelis Ghiossis added a comment -

          A Sample ScreenShot of the problem is attached

          Vangelis Ghiossis added a comment -

          I think this is issue relates to MCHANGES-144 but I do not get an exception

          Dennis Lundberg added a comment -

          The jira-results.xml file contains Greek characters. They are encoded using &#nnn; notation. The jira-report.html however has the encoding set to ISO-8859-1. That will not work. You will need to configure your site skin to use another encoding.

          Dennis Lundberg added a comment -

          MCHANGES-144 has been fixed now. Can you verify if that helps to solve this issue as well?

          Benson Margulies added a comment - - edited

          r1131489 | bimargulies | 2011-06-04 16:33:22 -0400 (Sat, 04 Jun 2011) | 5 lines

          MCHANGES-168: Fix non-Latin-script character handling.

          The actual repair here was the change to maven-reporting-impl version 2.1. However, I then went off and set up a
          way to test JIRA functionality without actually talking to JIRA. That involved a bit of refactoring and mocking.


            People

            • Assignee:
              Benson Margulies
              Reporter:
              Vangelis Ghiossis
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: