Maven 1
  1. Maven 1
  2. MAVEN-1753

Re-introduce xerces in maven's core dependencies

    Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta-1, 1.1-beta-2
    • Fix Version/s: 1.1-beta-3
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Because maven 1.1 works only with a jdk >= 1.4 whereas maven 1.0 requires at least the jdk 1.3, we removed xerces from the distribution (the xml parser API implemented by crimson is available in the jdk)
      The problem is that there's some bugs in crimson that are really annoying. Particularly there are a lot of issues with entities management.
      To fix them we have to readd xerces in the distribution.

        Issue Links

          Activity

          Arnaud Heritier added a comment -

          We'll upgrade to xerces 2.6.2

          Arnaud Heritier added a comment -

          The bootstrap (with tests for all plugins) was tested with the jdk 1.4.2 and the jdk 1.5
          For the jdk 1.5 I needed to change the permSize : -XX:MaxPermSize=128m

          Arnaud Heritier added a comment -

          xmlParserAPIs is deprecated.
          From: Michael Glavassevich :
          ===
          xmlParserAPIs.jar hasn't existed since Xerces-J 2.6.2. The jar which is
          now distributed with Xerces is called xml-apis.jar and originates from the
          xml-commons [1] project. Xerces-J 2.8.0 bundled xml-commons external
          1.3.03 [2] which can be found here [3] on ibiblio.
          [1] http://xml.apache.org/commons/
          [2] http://svn.apache.org/viewcvs.cgi/xml/commons/tags/xml-commons-external-1_3_03/java/external/
          [3] http://www.ibiblio.org/maven2/xml-apis/xml-apis/1.3.03/
          ===
          Xerces-J 2.8.0 also depends on the xml-commons resolver 1.1 [1]. It has
          been a dependency since Xerces-J 2.6.1.
          [1] http://www.ibiblio.org/maven2/xml-resolver/xml-resolver/1.1/

          Arnaud Heritier added a comment -

          I upgraded the core and the plugins to use :

          • Xerces 2.8.0.
          • xml-apis 1.3.03.
          • xml-resolver 1.1.
            It's tested with maven 1.1 beta 3 + jdk 1.4.2 & 1.5
            More tests are needed with maven 1.0.2 + jdk 1.3 & 1.4 & 1.5
          Jeff Jensen added a comment -

          Thanks Arnaud for making this change and publishing the snapshots.

          I am running your 4/30/06 M1.1-beta-3 snapshot, and it fixes a "SAXParser class not found" problem I had with trying to get QALab maven plugin to run. I also had to adjust a few of its dependencies (it was proven only on M1.0.2 according to Benoit, its author), but after that, nothing I did could get rid of that exception.

          Our CI product builds and nightly site gen are pounding on your snapshots daily...

          Jeff Jensen added a comment -

          (Per Arnaud's email request: Can you tell us what you had to change to use this plugin with maven 1.1)
          The dependecies changed to make it work were all parser related:

          • Removed dependency on xercesImpl jar
          • Added dependency on xerces 2.4.0 jar
          • Upgraded Xalan dependency to 2.7.0 jar

          Then the last problem was:
          java.lang.ClassNotFoundException: org/apache/xerces/parsers/SAXParser

          Upgrading to m1-b3-snapshot of 4/30/06 solved that one. I'm pretty sure I was using the snapshot just before 4/30/06 that did not work.

          Arnaud Heritier added a comment -

            People

            • Assignee:
              Arnaud Heritier
              Reporter:
              Arnaud Heritier
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: