Maven 1
  1. Maven 1
  2. MAVEN-1733

Bootstrap failure: Unable to delete directory ...

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.1-beta-3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Win XP, svn Checked out revision 355781.
    • Number of attachments :
      1

      Description

      bootstrap consistently fails. Attached is log for my last run.

      This is an interesting line from it:
      [exec] Caused by: Unable to delete directory C:\devroot\reference\maven\maven-1\plugins\trunk\genapp\src\plugin-test\nonStandardDirsTest\target

      I completely deleted the svn dirs and got latest. The error above prior was this:
      [exec] Root cause
      [exec] Unable to delete directory C:\devroot\reference\maven\maven-1\plugins\trunk\genapp\src\plugin-test\mavenHomeLocalTemplateTest\target

      And the run that failed before that one did not have an "unable to delete dir". (I did about 6 or so bootstraps today, trying to get it to work)

      They are on different plugins, such as Javadoc, Test Genapp. I have 3 of my last logs, and a couple of them are the test genapp (not the middle run of the 3).

      I hope something helps here, and this isn't some silly chase. Thanks again for looking into it.
      I tried to determine some environment thing for me.
      Oh, typing of environment, I am using JDK 1.5. Is that OK, or perhaps the prob?

        Issue Links

          Activity

          Arnaud Heritier added a comment -

          Not sure when we'll fix it

          Arnaud Heritier added a comment -

          It can be related to this note given in the javac ant task :

          Windows Note:When the modern compiler is used in unforked mode on Windows, it locks up the files present in the classpath of the <javac> task, and does not release them. The side effect of this is that you will not be able to delete or move those files later on in the build. The workaround is to fork when invoking the compiler.

          http://ant.apache.org/manual/CoreTasks/javac.html

          A workarround can be to set maven.compile.fork=true
          Since I applied it locally I didn't yet reproduce it.

          Arnaud Heritier added a comment -

          Can be related to some InputStream not properly closed in our code ??

          Arnaud Heritier added a comment -

          I didn't reproduce it for several months. I think we'll close it

          Michael Osipov added a comment -

          Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


            People

            • Assignee:
              Unassigned
              Reporter:
              Jeff Jensen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: