Maven 1
  1. Maven 1
  2. MAVEN-1258

Can't run replacetoken ant tag inside maven

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.0-rc2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Maven 1.0-rc2
      Windows 2000 SP4
      J2SDK 1.4.2_04
      Ant 1.5.3
    • Number of attachments :
      0

      Description

      Maven can't run replacetoken tag... Maven, Jelly or Werkz seams to
      delete the content inside replacetoken tag before ant is
      executed by maven...
      <replace file="teste.txt">
      <replacetoken>123</replacetoken>
      <replacevalue>12345</replacevalue>
      </replace>
      With this example, String "123" is deleted, and ant (executed by maven) can't run because "The token attribute must not be an empty string."

      I've tested it in my build.xml and works:
      <target name="teste4">
      <replace file="teste.txt">
      <replacetoken>123</replacetoken>
      <replacevalue>12345</replacevalue>
      </replace>
      </target>
      but with maven 1.0-rc2 (maven.xml), with the same code:
      <goal name="teste4">
      <replace file="teste.txt">
      <replacetoken>123</replacetoken>
      <replacevalue>12345</replacevalue>
      </replace>
      </goal>
      ...does not work.

      NOTE: There is no workaround for this, because replacetoken/replacevalue are used for special characters like '<' and '>' (inside <!CDATA[]>), and the tag <replace file="teste.txt" token="<" value=">"> won't work, because such characters are not allowed in this construction...

        Activity

        Wim Deblauwe added a comment -

        Ran into the same problem today with Maven 1.0.2. Luckally, I could use the attributes of the ant task in stead of the nested elements as a workaround.

        Brett Porter added a comment -

        confirmed bug

        Jacek Laskowski added a comment -

        A tested workaround in Maven 1.0.2 is to call <ant:ant/> from within maven.xml. The build.xml file would then look as follows:

        <?xml version="1.0" encoding="UTF-8"?>
        <project name="temporary workaround" default="replace">

        <target name="replace">
        <replace file="target/petstore-ear/customer-ejb/META-INF/ejb-jar.xml">
        <replacetoken><![CDATA[<ejb-relation-name></ejb-relation-name>]]></replacetoken>
        <replacevalue><Unable to render embedded object: File ([CDATA[<) not found.-- ejb-relation-name>Geronimo</ejb-relation-name -->]]></replacevalue>
        </replace>
        </target>

        </project>

        It works fine.

        Michael Osipov added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


          People

          • Assignee:
            Unassigned
            Reporter:
            Cassio Matsuo Nosshe
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: