Maven Assembly Plugin
  1. Maven Assembly Plugin
  2. MASSEMBLY-67

assembling dependent jars or snapshots uses timestamp formatted version instead of ${version}

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2-beta-1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      2

      Description

      I'm using the jar plugin to add my dependencies to the manifest. I'm also using the assembly plugin to package all dependencies into one archive. The problem is that the jar manifest adds my dependencies as "foo-SNAPHOT" and the archiver adds them as "foo-20041113.jar".

      This causes my snapshot classes to not be found at runtime.

      1. MJAR-28-Notes.txt
        6 kB
        Barrie Treloar
      2. MJAR-28-TestCases-Patch.txt
        43 kB
        Barrie Treloar

        Issue Links

          Activity

          Richard van der Hoff added a comment -

          ah right, thanks. I'll look into rolling my own build of it then...

          Barrie Treloar added a comment -

          I wrote up the steps I did to roll my own:
          http://docs.codehaus.org/display/MAVENUSER/Patching+Maven+Plugins

          Rudyolph Bistrovich added a comment -

          Don't you guys think it is an issue that depending on who did the deploy of the snapshot and who is doing the assembly you will have different results? ie.
          I wrote and deployed the snapshot and then do the assembly...dependency jars come out with -SNAPSHOT
          One of my developers does the assembly...dependency jars come out with the datestamp.

          We now have two flavours of assemblies zips that can wreak havok with predefined classpaths.

          It sounds like this is an issue with the deploy plugin itself since it should be consistent no matter who actually did the deploy.

          David Boden added a comment -

          Please see MASSEMBLY-91 for a description of a further problem with jars with classifiers and a workaround that you can use.

          Craig added a comment - - edited

          I just had problems somewhat related to this issue, but instead I was trying to get all timestamps for my snapshots. I wrote up my findings under another closed jira http://jira.codehaus.org/browse/MASSEMBLY-211?focusedCommentId=259987&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_259987


            People

            • Assignee:
              John Casey
              Reporter:
              Mark J. Titorenko
            • Votes:
              4 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: