Maven Assembly Plugin
  1. Maven Assembly Plugin
  2. MASSEMBLY-570

dependency includes filters don't match wildcard (*) in middle of coordinate segment

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      This works:

      <include>org.apache.maven.plugins:*-plugin</include>

      As does this:

      <include>org.apache.maven.plugins:maven-*</include>

      But NOT this:

      <include>org.apache.maven.plugins:maven*plugin</include>

        Issue Links

          Activity

          John Casey added a comment -

          root cause of the bug is in maven-common-artifact-filters-1.3

          John Casey added a comment -

          fixed in maven-common-artifact-filters, and added an integration test in the assembly plugin to verify the fix.


            People

            • Assignee:
              John Casey
              Reporter:
              John Casey
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: