Maven Assembly Plugin
  1. Maven Assembly Plugin
  2. MASSEMBLY-46

artifact classifier not used in outputFileNameMapping

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Linux
    • Number of attachments :
      0

      Description

      The classifier field of an artifact cannot be specified in the outputFileNameMapping.
      This means that attached Artifacts with the same type cannot be distinguished.
      I have a native code libraries attached to a java jar. Next, I have documentation etc attached to the artifact. All files have type .tgz.
      When I specify a depencySet I end up with only one file, instead of several. This is caused by the fact that classifier is removed from the name of the the original input artifact file.

      The workaround is to rename attached artifacts to a different type (rename .tgz to .tar.gz...).

        Issue Links

          Activity

          Jason van Zyl made changes -
          Field Original Value New Value
          Workflow jira [ 44590 ] Maven [ 44623 ]
          Brett Porter made changes -
          Link This issue is duplicated by MASSEMBLY-18 [ MASSEMBLY-18 ]
          Brett Porter made changes -
          Fix Version/s 2.1 [ 12219 ]
          Brett Porter made changes -
          Workflow Maven [ 44623 ] Maven New [ 49542 ]
          Allan Ramirez made changes -
          Assignee Jason van Zyl [ jason ] Allan Ramirez [ aramirez ]
          Allan Ramirez added a comment -

          Fixed in svn.

          Allan Ramirez made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]

            People

            • Assignee:
              Allan Ramirez
              Reporter:
              M. van der Plas
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: