Maven Assembly Plugin
  1. Maven Assembly Plugin
  2. MASSEMBLY-452

Shared Assembly Descriptor does not work in Maven3-alpha4

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2-beta-4
    • Fix Version/s: 2.2-beta-5
    • Component/s: None
    • Labels:
      None
    • Environment:
    • Number of attachments :
      1

      Description

      Following these instructions: http://maven.apache.org/plugins/maven-assembly-plugin/examples/sharing-descriptors.html
      it used to work fine in Maven 2.2.1 and earlier.

      With Maven 3.0-alpha-4, see the attached output.

        Activity

        Benjamin Bentmann added a comment -

        Fixed in r887583.

        Chad Lyon added a comment -

        Regression: This issue exists for version 2.2 of the plugin used with Maven 3.0!

        I have to configure my poms to use 2.2-beta-5 of the assembly plugin to be able to use a shared pom. It looks like 2.2 doesn't even try to search the classpath. Here is my env:

        Apache Maven 3.0 (r1004208; 2010-10-04 07:50:56-0400)
        Java version: 1.6.0_20
        Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
        Default locale: en_US, platform encoding: MacRoman
        OS name: "mac os x" version: "10.6.4" arch: "x86_64" Family: "mac"

        Please re-open this issue.

        May I also suggest a unit/integration/regression test be added?

        Kevin Calcagno added a comment -

        As of the 2.2 version of the plugin, the 'descriptors' element is interpreted strictly as a file path. To call your shared assemblies, use 'descriptorRefs" rather than 'descriptors' and drop the '.xml' file extension – just like you would call built-in descriptors like 'jar-with-dependencies' or 'bin'.

        This appears to be an intentional change (and cleans up the code a bit, IMHO). If you're curious, look at the diff between the 2.2-beta-5 and 2.2 tags for the class o.a.m.p.assembly.io.DefaultAssemblyReader.

        (Now they just need to fix the documentation on the sharing-descriptors.html page.)


          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Ben Tatham
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: