Community Mapbuilder
  1. Community Mapbuilder
  2. MAP-558

Mapbuilder fails to load addtional scripts with FF3.6

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5.1
    • Component/s: mapbuilder-lib
    • Labels:
      None
    • Environment:
      Windows XP, Firefox 3.6
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      With Firefox 3.6 the dynamic loading of scripts is broken, mapbuilder does not recognize Mozilla-browsers correctly anymore.
      Obviously document.readyState does now exist in Firefox 3.6 too.

      For testing: try to reach the component register:
      http://localhost:8080/mapbuilder/docs/register/

      Thanks to Rober's suggestions I was able to solve the problems (see attached path).
      I tested it in IE6, IE7, IE8 and FF2, FF3.5.8 and FF3.6 - it worked fine.

        Activity

        Hide
        Bernhard Kiselka added a comment -

        Fixed with revision 4047.

        Applied the patch.

        Show
        Bernhard Kiselka added a comment - Fixed with revision 4047. Applied the patch.

          People

          • Assignee:
            Bernhard Kiselka
            Reporter:
            Bernhard Kiselka
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2 hours
              2h
              Remaining:
              Remaining Estimate - 2 hours
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified