Maven Ant Tasks
  1. Maven Ant Tasks
  2. MANTTASKS-93

variables not interpolated while reading settings.xml

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.7
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I suspect that variables are not interpolated while reading settings.xml.

      For instance, I have set the environment variable REPO_DIR=c:/.m2repo. However, my <localRepository> setting is not respected if i use a ${env.variable} for the localRepository. I also tried adding -DREPO_DIR=c:/.m2repo to ANT_OPTS and using ${variable}, but still no luck.

      I was only able to test this in ~/.m2/settings.xml , and ~/.ant/settings.xml, because of MANTTASKS-92

      ~/.m2/settings.xml
      <settings>
          <!-- OK  -->
          <localRepository>c:/.m2repo</localRepository>
          <!-- NOT ok  -->
          <!--localRepository>${env.REPO_DIR}</localRepository-->
          <!-- NOT ok  -->
          <!--localRepository>${REPO_DIR}</localRepository-->
      </settings>
      

        Issue Links

          Activity

          Herve Boutemy added a comment -

          this is a duplicate of MANTTASKS-82


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Richard Ziegler
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: