Maven Ant Tasks
  1. Maven Ant Tasks
  2. MANTTASKS-11

antlib + http based repository + version range errors badly

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2.0.7
    • Component/s: None
    • Labels:
      None
    • Environment:
      maven 2.0 (release), antlib, ant, apache 2 webserver on windows
    • Number of attachments :
      0

      Description

      In my pom file, I have a dependency, it has no child dependencies beyond that looks like this:

      <dependency>
      <groupId>org.sporty</groupId>
      <artifactId>xwork</artifactId>
      <version>[1.0.5,1.1)</version>
      <scope>runtime</scope>
      </dependency>

      and use the following in my build script:

      <artifact:dependencies verbose="true" useScope="runtime" pathId="project.classpath.runtime">
      <artifact:pom file="pom.xml" />
      <artifact:remoteRepository url="$

      {project.repository}

      " layout="default" />
      </artifact:dependencies>

      The variable I have above is being set right per tests 1-3. The last test.. it gets strange.

      I deployed xwork, as an empty jar by accident, so don't be surprised there's nothing in the jar. But the dependency downloading from the webserver breaks horribly. I tested 4 scenarios:

      1. If I put in my pom as my remote repository as file://c:/temp/repository and deploy to there, the above pom works flawlessly.

      2 & 3. If I replace the range w/ a simple: <version>1.0.5</version> and set my repository to http://sporty.org/java/repository, it downloads fine as well. It works with the filesystem remote repository of my c:/temp... directory.

      4. If I use the http repository AND use a range version as I originally wanted, I get an ugly error:

      C:\development\eclipse 3.0\workspace\hibernate-3\common.xml:4: Unable to resolve
      artifact: Unable to get dependency information: Unable to read local copy of me
      tadata: Cannot read metadata from 'C:\Documents and Settings\sportee\.m2\reposit
      ory\org\sporty\xwork\maven-metadata-remote.xml': end tag name </pre> must match
      start tag name <hr> from line 11 (position: START_TAG seen ...</a>
      11-Oct-2005 17:52 - \n<hr></pre>... @11:11)
      org.sporty:xwork:null:jar

      from the specified remote repositories:
      remote (http://sporty.org/java/repository )
      Path to dependency:
      1) org.sporty:xdoclet-xwork:jar:1.0-SNAPSHOT

      The contents of the ...-remote.xml file, I see a directory listing, and not the contents of the repository file on the server. My naive guess is the repository file to look for is getting lost, or not passed, if it's in a hashmap, not being referenced properly...

      Thanks,
      -s

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            spencer portee
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: