Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.9
    • Fix Version/s: 2.0.10
    • Component/s: deploy task
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Maybe there is some support for SNAPSHOT deployment in the ant tasks, but the documentation (just one page?) doesn't show any features or examples. Please provide the ability to upload snapshots to a remote Maven repository (like mvn deploy).

        Issue Links

          Activity

          Dennis Lundberg added a comment -

          The section "Installing and Deploying Your Own Artifacts" talks about deploying to a remote repo.

          I would imagine that Maven Ant tasks works like Maven in this respect and will deploy to a snapshot repo if the artifact is a SNAPSHOT version. Haven't tried this yet, though.

          Ben Hale added a comment -

          The problem isn't deployment, it's what exactly i required to get it to follow -SNAPSHOT conventions. Because not every build system uses a version number with -SNAPSHOT some sort of munging will need to be done to make that work. But what this munging needs to look like isn't clear. A section in the documentation that describes exactly what will trigger the -SNAPSHOT behavior would be appreciated.

          Dennis Lundberg added a comment -

          I doubt that anything else than "-SNAPSHOT" at the end of the version will work. That is what Maven uses.

          Benjamin Bentmann added a comment -

          I doubt that anything else than "-SNAPSHOT" at the end of the version will work.

          Right, compare DefaultArtifact.isSnapshot()

          Herve Boutemy added a comment -

          yes, and Maven Ant Tasks can't do anything different from Maven here, since pom.xml is deployed along the artifact.
          I updated the doc to explain that both release and -SNAPSHOT versions are supported: see http://maven.apache.org/ant-tasks/reference.html#install


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Dave Syer
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: