Maven JXR
  1. Maven JXR
  2. JXR-92

${project.version} not substituted in xref/index.html for aggregate goal

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: maven2 jxr plugin
    • Labels:
      None
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      This is demonstrated in the existing 'aggregate' integration test. The resulting HTML contains:

      
       <div class="xleft">
              <span id="publishDate">Last Published: 2011-08-23</span>
                        &nbsp;| <span id="projectVersion">Version: ${project.version}</span>
                            </div>
      
      

      note that project.version isn't replaced by the actual version.

        Issue Links

          Activity

          Benson Margulies added a comment -

          Duplicate of JXR-93.


            People

            • Assignee:
              Benson Margulies
              Reporter:
              Benson Margulies
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: