JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6894

In 1.8 mode, generator.rb refers to non-existent generator_internal

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.7.0.pre1, JRuby 1.7.0.pre2
    • Fix Version/s: JRuby 1.7.0.RC1
    • Component/s: None
    • Labels:
      None
    • Environment:
      OpenVMS/Itanium, Debian GNU/Linux (unstable), Windows XP
    • Number of attachments :
      0

      Description

      Since Generator is now built in, strictly speaking "require 'generator'" is not needed. However, old application code (particularly old Ruby 1.8 code) still does require 'generator'. This fails as follows in --1.8 mode:

      LoadError: no such file to load – generator_internal
      require at org/jruby/RubyKernel.java:1015
      (root) at /f/Development/Live/jruby-1.7.0.preview2/lib/ruby/1.8/generator.rb:4

      This appears to have its root cause in JRUBY-4218. I gather at some point the internal structure changed, rendering this fix inoperable. In my own copy of 1.7.0.pre2 I have simply modified generator.rb, commenting out the require.

        Activity

        Hiro Asari added a comment -
        Ben Armstrong added a comment -

        Thanks. I understand rc1 is due soon. I'll wait and retest against that.

        Hiro Asari added a comment -
        Ben Armstrong added a comment -

        Ahh. Works nicely, thanks!


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Ben Armstrong
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: