Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.7.0.pre2
    • Fix Version/s: JRuby 1.7.0.RC1
    • Component/s: Encoding
    • Labels:
      None
    • Environment:
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      Unicode characters in rails views aren't displayed correctly (see https://github.com/taktsoft/jruby-rails-encoding-test).

      The problem is specific to preview2 and did not occur in preview1

        Activity

        Charles Oliver Nutter added a comment -

        I'm going to optimistically call this resolved. There were some socket and binary-related fixes after pre2 that resolved a lot of encoding problems in Rails and other libraries. The repository you provided now passes its test case.

        Please confirm with JRuby master (ideally) or RC1 after it's out.

        system ~/projects/jruby/tmp/jruby-rails-encoding-test $ rake test
        Run options: 
        
        # Running tests:
        
        .
        
        Finished tests in 0.074000s, 13.5135 tests/s, 13.5135 assertions/s.
        
        1 tests, 1 assertions, 0 failures, 0 errors, 0 skips
        
        Daniel Lehmann added a comment -

        Problem seems to be fixed for me. Thanks!


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Daniel Lehmann
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: