Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.0.pre2
    • Component/s: Miscellaneous
    • Labels:
      None
    • Environment:
      RHEL 5, java 1.6.0_22, Rails 3.2.6
    • Number of attachments :
      0

      Description

      Rails console in jruby 1.7.0 is missing its prompt: http://pastie.org/pastes/4294553/text

        Activity

        Charles Oliver Nutter added a comment -

        Indeed it is! Perhaps related to our move to jline2. Investigating.

        Charles Oliver Nutter added a comment -

        Actually, looks like it's related to our launching out-of-process always now:

        system ~/projects/jruby/testapp $ jruby -Xlaunch.inproc=true -S rails c
        Loading development environment (Rails 3.2.6)
        irb(main):001:0>
        
        Charles Oliver Nutter added a comment -
        commit 7cf0e2e95f7daaf94bec0fe8666691d4d05ced20
        Author: Charles Oliver Nutter <headius@headius.com>
        Date:   Tue Jul 24 01:34:19 2012 -0500
        
            Fix JRUBY-6788: Missing prompt in rails console
            
            The issue here was that because we no longer launch child JRuby
            processes within the same JVM, the console process that Rails
            execs no longer had access to the TTY. This in turn caused it to
            switch to "inspect mode" and to have no proper console prompts.
            
            We had already started the move to a native exec by doing so on
            Windows. My change expands true native exec to posix platforms and
            adds a configuration option native.exec to disable the changed
            behavior and keep the "subprocess" within the same JVM.
            
            *Most* specs and tests pass, except for some new reopen failures
            due to our reopen not actually reusing the same file descriptor
            (it simulates reopening by swapping the NIO Channel being used by
            the given ChannelDescriptor instance. I don't think this
            regression is avoidable.
        
        :100644 100644 74d0428... 8c2617a... M  spec/tags/1.8/ruby/core/io/reopen_tags.txt
        :100644 100644 0e6e011... 0f1786f... M  spec/tags/1.9/ruby/core/io/reopen_tags.txt
        :100644 100644 828ae58... 7786153... M  src/jruby/kernel19/jruby/process_util.rb
        :100644 100644 fbfbe89... 8768ed4... M  src/org/jruby/RubyKernel.java
        :100644 100644 fd9aa84... f3484a3... M  src/org/jruby/util/cli/Options.java
        

          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Edho Arief
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: