Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.1
    • Component/s: RubySpec
    • Labels:
      None
    • Number of attachments :
      0

      Description

      We seem to have passed up MRI on standard library release. We need to be bug for bug compatible plus we don't know how safe MRI trunk changes are.

        Issue Links

          Activity

          Charles Oliver Nutter added a comment -

          Ok, I asked ruby-core about release cycles, and they're preparing to spin a new 1.9.3 release soon. I'm not sure how soon that is, but it will certainly be before JRuby 1.7 final.

          I have also asked if it would be safe for us to roll to the most current stdlib from svn today, assuming the released version will be at least this patchlevel. So the problem is going to solve itself shortly, and after that we'll try to make sure we're matching patchlevel.

          FWIW, the main reason I had been keeping up with svn rather than actual releases was to pick up bug fixes that were taking too long to reach the public. Obviously we could have been picking up bugs at the same time.

          Charles Oliver Nutter added a comment -

          Still no help from ruby-core. It has been a couple months now and they have not released an updated 1.9.3.

          Charles Oliver Nutter added a comment -

          It's apparent there won't be a 1.9.3 release soon enough to get updates into 1.7.0, so we'll go with what we have and try to match them for 1.7.1.

          Hiro Asari added a comment -
          Kevin Menard added a comment -

          Thanks Hiro. I guess for accuracy, would someone with permissions mind changing the title of this issue to to say "p203" instead of "p204?"


            People

            • Assignee:
              Unassigned
              Reporter:
              Thomas E Enebo
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: