Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.0.pre2
    • Component/s: Application Error
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Apologies if my analysis is wrong on this one, but I've spent a couple hours on it thus far. I have a Rails 3.2 application that uses rspec. I load rspec up in a lib/tasks/rspec.rake file as is customary. In JRuby 1.6.7.2 this works just fine, but in JRuby 1.7, minitest's spec task always takes precedent. I assume Rails is loading this up some place as I don't have test-unit anywhere in my code or Gemfile.

      I've tried both with and without invoke dynamic enabled. In both cases minitest's spec task takes precedence. What's really odd is the "rake -T" output includes my description strings, indicating rake thinks my tasks are the ones to use.

        Activity

        Kevin Menard added a comment -

        Sorry for the noise. I think the issue is I had a stray assert_equal inserted in one spec.


          People

          • Assignee:
            Unassigned
            Reporter:
            Kevin Menard
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: