Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: JRuby 1.6.7
    • Fix Version/s: None
    • Component/s: Extensions
    • Labels:
      None
    • Environment:
      Fedora 17
    • Number of attachments :
      0

      Description

      The MRI Ruby 1.9.3 came with some libraries split into Gems - for example bigdecimal and io-console. In Fedora we unbundled them and made them normal Gems. The reason to unbundle them is simple - if newer versions are installed, they only get picked up if they are in gemspec files or Gemfiles and installed as normal Gems - otherwise the versions in Ruby library path get picked up by Bundler.

      So the problem is, that we now need to add e.g. bigdecimal to gemspec files, but that doesn't work with JRuby, because there is no bigdecimal (or io-console) Gem for JRuby. Would it be possible to provide these (because they are written in C, some kind of Java counterpart would be needed)? For the related issues, see [1] (fake gems problems in general) and [2] (activesupport uses bigdecimal, but doesn't have it in gemspec).

      [1] https://bugs.ruby-lang.org/issues/6124
      [2] https://github.com/rails/rails/issues/5355

        Activity

        Hiro Asari added a comment -

        OK, so placing bigdecimal in Gemfile is bad (or bigdecimal gem can't be installed on JRuby).

        Bohuslav "Slavek" Kabrda added a comment -

        Yes, it is bad, but it shouldn't

        Charles Oliver Nutter added a comment -

        It looks like the MRI issue has been assigned, but there doesn't appear to be any action yet. We are largely waiting on them to either give us access to release -java versions of these gems, or to do that themselves.

        Charles Oliver Nutter added a comment -

        Still no action from ruby-core. Grumble.

        Charles Oliver Nutter added a comment -

        JRuby has moved bug tracking to Github, accessible via our Github page at https://github.com/jruby/jruby/issues, or via http://bugs.jruby.org. In addition, this bug has not been updated in over two years.

        We have decided to close down these old JIRA issues.

        If your report is still a problem on current JRuby versions (1.7.18 or master/9.0.0.0), please re-file the bug at http://bugs.jruby.org.

        You can contact us on the JRuby mailing lists, Freenode IRC channel #jruby, or the @jruby Twitter account if you are unsure how to proceed.


          People

          • Assignee:
            Unassigned
            Reporter:
            Bohuslav "Slavek" Kabrda

            Dates

            • Created:
              Updated:
              Resolved: