JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6650

when running the build I get a java.lang.AssertionError during jruby -S maybe_install_gems hoe rdoc

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: None
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      when running the build I get a java.lang.AssertionError during jruby -S maybe_install_gems hoe rdoc. see: http://pastie.org/3870978

      I can bypass the error by running "jruby -S maybe_install_gems hoe rdoc" (which succeeds). Then I can run ant dist again and the build succeeds by skipping the gem install. see: http://pastie.org/3871015

        Activity

        Wayne Meissner added a comment -

        Looks like this is a bug in RubyTime.java. Should probably be using internal variables for nano_num, nano_den, offset.

        Wayne Meissner added a comment -

        You can also reproduce this by enabling assertions and trying to unmarshal a Time instance:

        jruby -J-ea -e 'p Marshal.load("\x04\bIu:\tTime\r\xE1\x10\x1C\x80\x88\a\xD2b\x06:\voffseti\x02\xA0\x8C")'
        
        Wayne Meissner added a comment - - edited

        I committed a fix for this in 75c544898087e8619102b68a9977101b19cc1bcb

        Thomas E Enebo added a comment -

        This appears to be fixed now. Wayne, is this ok to close or were you leaving open for a test?


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            jeremy deininger
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: