JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6640

stat.st_gid unsupported or native support failed to load org/jruby/RubyFileStat.java:432

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.7
    • Fix Version/s: JRuby 1.7.0.RC1
    • Component/s: None
    • Labels:
    • Environment:
    • Number of attachments :
      2

      Description

      jruby-1.6.7.2 raises

      stat.st_gid unsupported or native support failed to load org/jruby/RubyFileStat.java:432:in `gid' /home/hermes/.rbenv/versions/jruby-1.6.7.2/lib/ruby/gems/1.8/gems/activesupport-3.2.3/lib/active_support/core_ext/file/atomic.rb:39:in `atomic_write'

      The same occurs at least for jruby-1.6.7 and/or java version "1.6.0_22"

        Activity

        Charles Oliver Nutter added a comment -

        Part of Solaris re-fit of FFI stuff.

        Charles Oliver Nutter added a comment -

        We need someone to contribute builds of jffi's native bits for Solaris on Sparc. Both sparc and sparcv9 are empty right now.

        https://github.com/jnr/jffi/

        Clayton O'Neill added a comment -

        I've built sparc and sparcv9 jffi jar's, but the sparc one fails most of the tests. I'll attach the sparcv9 one since it appears to work. See this gist for details on the sparc test failures: https://gist.github.com/3743618

        Charles Oliver Nutter added a comment -

        Clayton: Hey, that's progress! We'll see if we can figure out the failures...if it fails most of them, there's probably something fundamental wrong.

        I'll get the sparcv9 library incorporated into jffi.

        Charles Oliver Nutter added a comment -

        Clayton: It looks like it's simply having trouble finding the native library for the sparc jar. Can you confirm that it's actually in there? This may be something really simple.

        Clayton O'Neill added a comment -

        The problem is that it's building a sparcv9 libjffi even on sparc. I'm looking at it to see what I can do about that.

        Clayton O'Neill added a comment -

        I've submitted a pull request to fix the 32bit sparc build problem - https://github.com/jnr/jffi/pull/2

        I'll attach the 32bit jffi jar to this ticket in a few minutes.

        Charles Oliver Nutter added a comment -

        Ah-ha! Great find! I'll pull your request into jffi and look forward to the sparc jar.

        Charles Oliver Nutter added a comment -

        Thanks a bunch, Clayton! I've pulled your jffi request and gotten the binaries into jffi and JRuby.

        commit 04569b5a5f8f7c47797d017f4b893a5b727c0eb5
        Author: Charles Oliver Nutter <headius@headius.com>
        Date:   Tue Sep 18 15:06:31 2012 -0500
        
            Fix JRUBY-6162 with sparc and sparcv9 SunOS jffi bits.
        
        :100644 100644 8235a34... 46c3b65... M	build_lib/jffi-sparc-SunOS.jar
        :100644 100644 8235a34... 306788c... M	build_lib/jffi-sparcv9-SunOS.jar
        

          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Thomas Sonntag
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: