Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby-OSSL 0.7.5, JRuby-OSSL 0.7.6
    • Fix Version/s: JRuby 1.7.18
    • Component/s: OpenSSL
    • Labels:
      None
    • Environment:
      ubuntu rvm
    • Number of attachments :
      3

      Description

      file=File.open("encrypted_rsa_key")
      OpenSSL::PKey::RSA.new(file.read,"this would be my passphrase") => OpenSSL::PKey::RSAError: Neither PUB key nor PRIV key

      1. output.log
        6 kB
        Richard Nienaber
      2. serverkey.pem
        1 kB
        John-Paul Sitarski
      3. test.rb
        0.1 kB
        Richard Nienaber

        Activity

        Hiroshi Nakamura added a comment -

        Note: The pem uses PBES2 instead of general PBKDF2 used in PKCS#12. We should support this.

        Hiroshi Nakamura added a comment -
        commit ebf5545f302f185f89a9e059f2b77aca0a8c1159
        Author: Hiroshi Nakamura <nahi@ruby-lang.org>
        Date:   Sun May 13 14:09:33 2012 +0900
        
            JRUBY-6622: Support loading encrypted RSA key with PBES2
            
            Yet another BouncyCastle dependency.  Root cause is because we depend on
            BC for ASN.1.
        

        Can you try master branch of jruby-ossl? Our CI is likely stopping now.

        Hiroshi Nakamura added a comment -

        Thanks to Hiro, Mr. Jenkins has woke up. Please grab the latest gem (0.7.7.dev) from http://ci.jruby.org/job/jruby-ossl/

        Gregory Manushkin added a comment - - edited

        hi! it seems this ticket repeat or bind with 6826. i've got the same problem with jruby-1.7.1 and jruby-openssl-0.8.2

        Richard Nienaber added a comment -

        This looks to be working on JRuby 1.7.18 (1.8/1.9) and JRuby HEAD (c1be61a). I've attached the test code and output.log.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Pedro Rolo
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: