Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      There was a spurious CI failure before, at line 295 in test/test_socket.rb, test test_can_create_socket_server_and_blocking_select_blocks_on_it()

      I think the select timeout needs to be lengthened, so the Timeout::timeout is more likely to trigger before select wakes up (sleep granularity and context switching may cause them to occur not in the order desired).

        Activity

        Yoko Harada added a comment -

        This might be related to https://jira.codehaus.org/browse/JRUBY-4614 .

        The issue has been marked as resolved since it wasn't reproduce-able. However, I have this problem still now on master.

        Charles Oliver Nutter added a comment -

        I bumped the select timeout to 1s; hopefully that's long enough for even a loaded machine to trigger the 0.1s Timeout.

        Yoko: Open a new bug for your issue and we'll work on fixing it. Provide a thread dump if possible.

        Charles Oliver Nutter made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s JRuby 1.7 [ 17049 ]
        Resolution Fixed [ 1 ]
        Thomas E Enebo added a comment -

        This was also the failure killing windows build on CI. It may not be spurious on Windows though...it may just be a coincidence perhaps.

        Yoko Harada added a comment -

          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Wayne Meissner
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: