Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: None
    • Component/s: Performance, Ruby 1.9.3
    • Labels:
    • Number of attachments :
      2

      Description

      The error occurs during the bootstrap phase of an application I have been developing. In JRuby 1.6.7, there are no errors and the application is able to launch successfully. No changes to the code have been made between tests.

      Some minor digging found that the NameError is raised when JRuby attempts to evaluate the line "require 'jruby'", called at the top of the initial script.

      The included attachment uses the same command line information to execute as the JRuby 1.6.7 test, and contains verbose output.

      The full command is:
      jruby.bat -v -Ilib/ -J-Djruby.thread.pooling=true --fast --server --1.9 lib/gryphon.rb

      1. output2.log
        22 kB
        Justin Petrillo
      2. output3.log
        18 kB
        Justin Petrillo

        Activity

        Hiro Asari added a comment -

        Does removing any of your extra flags affect whether you get the exception?

        Justin Petrillo added a comment -

        Removing all JRuby specific commands and using

        jruby.bat -v -Ilib/ lib/gryphon.rb

        allows the application to successfully launch, however it appears there are still some warnings about require calls and a ClassNotFoundException being thrown for org.objectweb.asm.ClassReader .

        Adding the new output as output3.log

        Justin Petrillo added a comment -

        ClassNotFoundException persists after JRuby-specific flags are removed.

        Hiro Asari added a comment -

        Is org.objectweb.asm.ClassReader found in your jruby.jar?

        $ jar tvf lib/jruby.jar | grep ClassReader
         17994 Sat Oct 29 08:09:54 EDT 2011 org/objectweb/asm/ClassReader.class
        
        Justin Petrillo added a comment -

        Versions 1.6.7 and 1.7.0-dev of JRuby's jruby.jar files do not seem to include that path or any reference to a ClassReader class.

        Hiro Asari added a comment -

        Where did you get JRuby? I just checked snapshots from http://ci.jruby.org, as well as the released 1.6.7, and they all have it.

        Justin Petrillo added a comment -

        1.6.7 is from the JRuby.org website, I believe using the 64bit executable.

        1.7 was from http://ci.jruby.org/snapshots/master/

        Hiro Asari added a comment -
        C:\Users\asari\Downloads\jruby-bin-1.6.7\jruby-1.6.7>.\bin\jruby -S irb
        irb(main):001:0> RUBY_DESCRIPTION
        => "jruby 1.6.7 (ruby-1.8.7-p357) (2012-02-22 3e82bc8) (Java HotSpot(TM) 64-Bit Server VM 1.6.0_29) [Windows 7-amd64-java]"
        irb(main):002:0> require 'java'
        => true
        
        Charles Oliver Nutter added a comment -

        We'll call this "Cannot Reproduce". It's likely it was something glitchy in the dev builds during this period.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Justin Petrillo
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: