Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.6
    • Fix Version/s: None
    • Component/s: Standard Library
    • Labels:
      None
    • Environment:
      mac osx 10.7
    • Number of attachments :
      0

      Description

      This is directly caused by the Open3.popen3 hack as explained in http://jira.codehaus.org/browse/JRUBY-6409.

      $ irb -ropen3
      >> ar = Open3.capture3('ls')
      NoMethodError: undefined method `value' for nil:NilClass
      /Users/me/Developer/.rbenv/versions/jruby-1.6.7/lib/ruby/1.9/open3.rb:281:in `capture3'
      org/jruby/RubyIO.java:3773:in `popen3'
      /Users/me/Developer/.rbenv/versions/jruby-1.6.7/lib/ruby/1.9/open3.rb:74:in `popen3'
      /Users/me/Developer/.rbenv/versions/jruby-1.6.7/lib/ruby/1.9/open3.rb:271:in `capture3'

        Issue Links

          Activity

          Hiro Asari added a comment -

          I'm going to resolve this as a duplicate of JRUBY-6409.


            People

            • Assignee:
              Hiro Asari
              Reporter:
              Gabriel Horner
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: