Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: JRuby 1.6.5, JRuby 1.6.6
    • Fix Version/s: JRuby 1.7.0.pre2
    • Component/s: Windows
    • Labels:
    • Environment:
      Windows, JDK 7u3
    • Number of attachments :
      0

      Description

      Repro steps:
      1. Install/Download JRuby 1.6.5, 1.6.6 or 1.6.7
      2. Install JDK 7u3 update
      3. On Windows command prompt, type jirb
      4. type
      require 'net/ftp'
      ftp = Net::FTP.open('ftp_server', 'anonymous', 'your_email_id')
      5. On success, type ftp.nlst or ftp.ls

      throws 'ECONNRESET' Connection reset by peer

      This works under JDK 6.

        Activity

        Charles Oliver Nutter added a comment -

        Appears to be working ok on master, perhaps due to socket-subsystem rewrites in JRuby 1.7.

        Gaurang added a comment -

        Get the same "connection reset by peer" on JDK 7 update 5 with jruby-complete-1.7.0.RC2.jar

        Gaurang added a comment -

        Looks like a Java 7 issue on Windows platform as per http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7077696.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Gaurang
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: