Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.6, JRuby 1.6.7
    • Fix Version/s: JRuby 1.7.0.pre2
    • Component/s: Core Classes/Modules
    • Labels:
    • Environment:
      OpenIndiana b151a x86_64
      OpenSolaris 2009.06 x86
    • Number of attachments :
      0

      Description

      I noticed strange error messages when trying to install any gem using RubyGems:

      ERROR:  While executing gem ... (Errno::ENOENT)
          No such file or directory - 
      

      After doing some investigating I narrowed down the problem to File.directory?:

      $ irb
      irb(main):001:0> JRUBY_VERSION
      => "1.6.7"
      irb(main):002:0> File.directory? '/'
      => false
      irb(main):003:0> bklang@openindiana:~/jruby-1.6.7$ uname -a
      SunOS openindiana 5.11 oi_151a i86pc i386 i86pc Solaris
      

      I have verified this is an issue on Solaris, but NOT an issue on OS X. Also this is a regression, as the issue is not present in JRuby-1.6.5.1 and earlier:

      $ irb
      irb(main):001 > JRUBY_VERSION
       => "1.6.5.1" 
      irb(main):002 > File.directory? "/"
       => true 
      

        Issue Links

          Activity

          Scott Severtson added a comment -

          I can confirm that Ben Summers' solution resolves the File.directory? issue when applied to JRuby 1.6.7 on Solaris 10 x86.

          I can also confirm that "-Xnative.enabled=false" workaround resolves the same issue, but introduces other problems due to some file operations not being implemented in non-native code.

          Charles Oliver Nutter added a comment -

          This should be resolved now in jnr-posix, but leaving this open to ensure we ship the latest jnr-posix with 1.7pre2.

          Charles Oliver Nutter added a comment -

          Tom is in the process of updating jnr-posix, so I'm marking this resolved.

          Unic Man added a comment -

          Can I know the GA date of 1.7. We also need to have Solaris support and we have just migrated to rails 3.2.x platform on rails 1.6.7 and our release is totally stuck due to this defect.

          Thomas E Enebo added a comment -

          Unic man, barring significant blocker we are looking at tomorrow (friday) or possibly Monday.


            People

            • Assignee:
              Charles Oliver Nutter
              Reporter:
              Ben Klang
            • Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: