Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Compiler
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Stacktrace as followed:

      RuntimeError: could not compile and compile mode is 'force': /data/mdm/shared/bundle/jruby/1.9/gems/activesupport-3.2.1/lib/active_support/core_ext/string/inflections.rb
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/shared/bundle/jruby/1.9/gems/activesupport-3.2.1/lib/active_support/inflector.rb:7
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/shared/bundle/jruby/1.9/gems/activesupport-3.2.1/lib/active_support/core_ext/module/introspection.rb:1
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/shared/bundle/jruby/1.9/gems/activesupport-3.2.1/lib/active_support/dependencies.rb:6
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/shared/bundle/jruby/1.9/gems/activerecord-3.2.1/lib/active_record/base.rb:10
      (root) at /data/mdm/releases/20120222225853/lib/core/group.rb:1
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/releases/20120222225853/lib/core.rb:1
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/releases/20120222225853/lib/partner-mdm.rb:28
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/releases/20120222225853/config/boot.rb:13
      require at org/jruby/RubyKernel.java:1036
      (root) at /data/mdm/shared/bundle/jruby/1.9/gems/activesupport-3.2.1/lib/active_support/core_ext/string/inflections.rb:7
      instance_eval at org/jruby/RubyBasicObject.java:1726
      initialize at file:/data/mdm/shared/bundle/jruby/1.9/gems/jruby-rack-1.1.3/lib/jruby-rack-1.1.3.jar!/vendor/rack-1.3.6/rack/builder.rb:51
      (root) at /data/mdm/releases/20120222225853/config.ru:1

        Activity

        Owen Ou added a comment - - edited

        More info

        jruby 1.6.6 (ruby-1.9.2-p312) (2012-01-30 5673572) (Java HotSpot(TM) 64-Bit Server VM 1.6.0_26) [linux-amd64-java]
        Time: 2012-02-23 01:21:44 UTC
        Server: Apache Tomcat/7.0.23

        — Context Init Parameters:
        jruby.compat.version = 1.9.2
        jruby.initial.runtimes = 1
        jruby.max.runtimes = 1
        jruby.min.runtimes = 1
        public.root = /public
        rack.env = staging
        rackup.path = config.ru

        Charles Oliver Nutter added a comment -

        So far I have been unable to reproduce this...master and 1.6.6 both seem to be able to compile this file just fine.

        Owen Ou added a comment - - edited

        hmm...the OS having the bug was Gentoo. I am guessing that's a OS specific bug. I dont have the problem on Ubuntu either. Please let me know if you want any more info that could help you debug.

        Thanks,
        Owen

        Charles Oliver Nutter added a comment -

        Optimistically calling this fixed; we've been running 1.9-mode tests for a long time and precompilation is a part of these tests.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Owen Ou
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: